Visio Shapes とBox Data を連携

詳細情報をご希望ですか?

無償トライアル:

ダウンロードへ

製品の詳細情報へ:

Box ODBC Driver

Box ODBC Driver は、ODBC 接続をサポートするさまざまなアプリケーションからBox のリアルタイムデータ連携を実現するパワフルなツールです。

RDB にアクセスするときと同感覚でBox にアクセスし、標準ODBC Driver インターフェースを通じて読み出し、書き込み、更新が可能に。



Visio master shapes での変更を自動的にBox data に更新。

Automate the process of entering data into Visio diagrams and keeping your diagrams up to date with the CData ODBC Driver for Box. The driver surfaces Box data as an ODBC data source that can be accessed by applications with built-in ODBC support like Microsoft Office. This article shows how to create a simple diagram to start brainstorming about Visio projects linked to Box data.

Connect to Box as an ODBC Data Source

If you have not already, first specify connection properties in an ODBC DSN (data source name). This is the last step of the driver installation. You can use the Microsoft ODBC Data Source Administrator to create and configure ODBC DSNs.

Box は、認証にOAuth スタンダードを使用します。Box への認証には、登録アプリのOAuthClientId、OAuthClientSecret、CallbackURL を入力します。詳細はヘルプドキュメントの「はじめに」を参照してください。

尚、本製品はBox のファイルの一覧表示やユーザー管理情報の取得用です。Box に保管されているExcel、CSV、JSON などのファイル内のデータを読み込みたい場合には、Excel DriverCSV DriverJSON Driver をご利用ください。

Connect Box Data to Diagrams

Follow the steps below to use the Data Selector Wizard to import data into your diagram.

  1. Open Visio and click File -> New. Open the Brainstorming template.
  2. On the Data tab, click Link Data to Shapes.
  3. Select the ODBC option and select ODBC DSN.
  4. Select the DSN for Box, select the table you want to import, and finish the wizard. This article uses Files as an example.

Link Box Entities to Shapes

Follow the steps below to create a simple diagram that shows how to create shapes from your data, one of the ways to link Box entities to shapes:

  1. Click Brainstorming Shapes and drag a main topic onto the drawing page. Enter Files as the text of the main topic.
  2. Click Topic.
  3. Select a row in the External Data window and drag it onto the drawing page.
  4. Right-click the Topic shape and click Data -> Edit Data Graphic.
  5. Click New Item.
  6. In the Data Field menu, select a column. In the Displayed As menu, select how to display them.
  7. Drag a few other Box entities onto the drawing page and add association lines back to the main topic, Files. New topics have the same configuration: Numeric columns displayed in data bars stand out in contrast to other Files entities.

You can refresh your diagram from the Data tab, synchronizing your shapes with the external Box data.