Visio Shapes とe-Sales Manager Data を連携

詳細情報をご希望ですか?

無償トライアル:

ダウンロードへ

製品の詳細情報へ:

e-Sales Manager Remix ODBC Driver

e-Sales Manager ODBC ドライバーは、ODBC 接続をサポートする任意のアプリケーションからリアルタイムe-Sales Manager データに直接接続できる強力なツールです。標準のODBC ドライバーインタフェースを使用して、データベースのようにe-Sales Manager にアクセスし、Customer、Product、Business などの読み出し、書き込み、および更新を実行できます。



Visio master shapes での変更を自動的にe-Sales Manager data に更新。

Automate the process of entering data into Visio diagrams and keeping your diagrams up to date with the CData ODBC Driver for e-Sales Manager. The driver surfaces e-Sales Manager data as an ODBC data source that can be accessed by applications with built-in ODBC support like Microsoft Office. This article shows how to create a simple diagram to start brainstorming about Visio projects linked to e-Sales Manager data.

Connect to e-Sales Manager as an ODBC Data Source

If you have not already, first specify connection properties in an ODBC DSN (data source name). This is the last step of the driver installation. You can use the Microsoft ODBC Data Source Administrator to create and configure ODBC DSNs.

e セールスマネージャー Remix に接続するには、User、Passowrd、URL、TenantId パラメータが必要です。

  • User:API を実行するためのログインユーザーのユーザーID。
  • Password:API を実行するためのログインユーザーのユーザーパスワード
  • URL:e-Sales Manager Remix エンドポイントへのURL。例:https://XXX.softbrain.co.jp
  • TenantId:e-Sales Manager Remix テナント名のTenantd。例:cdata

Connect e-Sales Manager Data to Diagrams

Follow the steps below to use the Data Selector Wizard to import data into your diagram.

  1. Open Visio and click File -> New. Open the Brainstorming template.
  2. On the Data tab, click Link Data to Shapes.
  3. Select the ODBC option and select ODBC DSN.
  4. Select the DSN for e-Sales Manager, select the table you want to import, and finish the wizard. This article uses Customer as an example.

Link e-Sales Manager Entities to Shapes

Follow the steps below to create a simple diagram that shows how to create shapes from your data, one of the ways to link e-Sales Manager entities to shapes:

  1. Click Brainstorming Shapes and drag a main topic onto the drawing page. Enter Customer as the text of the main topic.
  2. Click Topic.
  3. Select a row in the External Data window and drag it onto the drawing page.
  4. Right-click the Topic shape and click Data -> Edit Data Graphic.
  5. Click New Item.
  6. In the Data Field menu, select a column. In the Displayed As menu, select how to display them.
  7. Drag a few other e-Sales Manager entities onto the drawing page and add association lines back to the main topic, Customer. New topics have the same configuration: Numeric columns displayed in data bars stand out in contrast to other Customer entities.

You can refresh your diagram from the Data tab, synchronizing your shapes with the external e-Sales Manager data.