今すぐお試しください!

製品の詳細CData ODBC Driver for Garoon を確認して、無償評価版をダウンロード:

今すぐダウンロード

Visio Shapes とGaroon Data を連携

Visio master shapes での変更を自動的にGaroon data に更新。

Automate the process of entering data into Visio diagrams and keeping your diagrams up to date with the CData ODBC Driver for Garoon. The driver surfaces Garoon data as an ODBC data source that can be accessed by applications with built-in ODBC support like Microsoft Office. This article shows how to create a simple diagram to start brainstorming about Visio projects linked to Garoon data.

Connect to Garoon as an ODBC Data Source

If you have not already, first specify connection properties in an ODBC DSN (data source name). This is the last step of the driver installation. You can use the Microsoft ODBC Data Source Administrator to create and configure ODBC DSNs.

Garoon への認証は、パスワード認証、Basic 認証、クライアントSSL をサポートしています。

パスワード認証

Garoon への認証には、以下を設定する必要があります。

  • Url:アカウントのURL。
  • User:アカウントのユーザー名。
  • Password:アカウントのパスワード。

Basic 認証

Basic 認証セキュリティ機能がドメインに設定されている場合は、BasicAuthUser とBasicAuthPassword の追加ログイン資格情報を指定します。Basic 認証ではUser とPassword に加えて、これらのクレデンシャルが必要です。

クライアントSSL

Basic 認証の代わりに、クライアント証明書を指定して本製品を認証できます。 SSLClientCert、SSLClientCertType、 SSLClientCertSubject、 およびSSLClientCertPassword を設定します。 さらに、User とPassword をGaroon のログイン資格情報に設定します。

Connect Garoon Data to Diagrams

Follow the steps below to use the Data Selector Wizard to import data into your diagram.

  1. Open Visio and click File -> New. Open the Brainstorming template.
  2. On the Data tab, click Link Data to Shapes.
  3. Select the ODBC option and select ODBC DSN.
  4. Select the DSN for Garoon, select the table you want to import, and finish the wizard. This article uses Events as an example.

Link Garoon Entities to Shapes

Follow the steps below to create a simple diagram that shows how to create shapes from your data, one of the ways to link Garoon entities to shapes:

  1. Click Brainstorming Shapes and drag a main topic onto the drawing page. Enter Events as the text of the main topic.
  2. Click Topic.
  3. Select a row in the External Data window and drag it onto the drawing page.
  4. Right-click the Topic shape and click Data -> Edit Data Graphic.
  5. Click New Item.
  6. In the Data Field menu, select a column. In the Displayed As menu, select how to display them.
  7. Drag a few other Garoon entities onto the drawing page and add association lines back to the main topic, Events. New topics have the same configuration: Numeric columns displayed in data bars stand out in contrast to other Events entities.

You can refresh your diagram from the Data tab, synchronizing your shapes with the external Garoon data.

 
 
ダウンロード