Visio Shapes と Data を連携

Visio master shapes での変更を自動的に data に更新。

Automate the process of entering data into Visio diagrams and keeping your diagrams up to date with the CData ODBC Driver for . The driver surfaces data as an ODBC data source that can be accessed by applications with built-in ODBC support like Microsoft Office. This article shows how to create a simple diagram to start brainstorming about Visio projects linked to data.

Connect to as an ODBC Data Source

If you have not already, first specify connection properties in an ODBC DSN (data source name). This is the last step of the driver installation. You can use the Microsoft ODBC Data Source Administrator to create and configure ODBC DSNs.

Google uses the OAuth authentication standard. To access Google APIs on behalf on individual users, you can use the embedded credentials or you can register your own OAuth app.

OAuth also enables you to use a service account to connect on behalf of users in a Google Apps domain. To authenticate with a service account, you will need to register an application to obtain the OAuth JWT values.

In addition to the OAuth values, to access Google data you will need the Email of the Google account. See the "Getting Started" chapter in the help documentation for a guide to using OAuth.

Connect Data to Diagrams

Follow the steps below to use the Data Selector Wizard to import data into your diagram.

  1. Open Visio and click File -> New. Open the Brainstorming template.
  2. On the Data tab, click Link Data to Shapes.
  3. Select the ODBC option and select ODBC DSN.
  4. Select the DSN for , select the table you want to import, and finish the wizard. This article uses GDrive as an example.

Link Entities to Shapes

Follow the steps below to create a simple diagram that shows how to create shapes from your data, one of the ways to link entities to shapes:

  1. Click Brainstorming Shapes and drag a main topic onto the drawing page. Enter GDrive as the text of the main topic.
  2. Click Topic.
  3. Select a row in the External Data window and drag it onto the drawing page.
  4. Right-click the Topic shape and click Data -> Edit Data Graphic.
  5. Click New Item.
  6. In the Data Field menu, select a column. In the Displayed As menu, select how to display them.
  7. Drag a few other entities onto the drawing page and add association lines back to the main topic, GDrive. New topics have the same configuration: Numeric columns displayed in data bars stand out in contrast to other GDrive entities.

You can refresh your diagram from the Data tab, synchronizing your shapes with the external data.

 
 
ダウンロード