Visio Shapes とMySQL Data を連携

詳細情報をご希望ですか?

無償トライアル:

ダウンロードへ

製品の詳細情報へ:

MySQL ODBC Driver

MySQL ODBC ドライバーは、ODBC 接続をサポートする任意のアプリケーションからリアルタイムなMySQL データに直接接続できるパワフルなツールです。標準のODBC ドライバーインタフェースを使用して、事実上どこからでもMySQL データベースにアクセスできます。



Visio master shapes での変更を自動的にMySQL data に更新。

Automate the process of entering data into Visio diagrams and keeping your diagrams up to date with the CData ODBC Driver for MySQL. The driver surfaces MySQL data as an ODBC data source that can be accessed by applications with built-in ODBC support like Microsoft Office. This article shows how to create a simple diagram to start brainstorming about Visio projects linked to MySQL data.

Connect to MySQL as an ODBC Data Source

If you have not already, first specify connection properties in an ODBC DSN (data source name). This is the last step of the driver installation. You can use the Microsoft ODBC Data Source Administrator to create and configure ODBC DSNs.

Server およびPort プロパティがMySQL への接続には必須です。IntegratedSecurity をFALSE に設定した場合、User、Password も必須になります。 オプションで、Database を設定することもできます。Database は設定がない場合すべてのデータベースを使えるようになります。

パスワード方式によるSSH 接続

パスワード方式によるSSH接続時に必要なプロパティ一覧を以下に示します。

  • User: MySQL のユーザ
  • Password: MySQL のパスワード
  • Database: MySQL の接続先データベース
  • Server: MySQL のサーバー
  • Port: MySQL のポート
  • UserSSH: "true"
  • SSHAuthMode: "Password"
  • SSHPort: SSH のポート
  • SSHServer: SSH サーバー
  • SSHUser: SSH ユーザー
  • SSHPassword: SSH パスワード

接続文字列形式では以下のようになります。User=admin;Password=adminpassword;Database=test;Server=mysql-server;Port=3306;UseSSH=true;SSHAuthMode=Password;SSHPort=22;SSHServer=ssh-server;SSHUser=root;SSHPassword=sshpasswd;

公開鍵認証方式方式によるSSH 接続

公開鍵認証によるSSH接続時に必要なプロパティ一覧を以下に示します。

  • User: MySQL のユーザ
  • Password: MySQL のパスワード
  • Database: MySQL の接続先データベース
  • Server: MySQL のサーバー
  • Port: MySQL のポート
  • UserSSH: "true"
  • SSHAuthMode: "Public_Key"
  • SSHClientCertType: キーストアの種類
  • SSHPort: SSH のポート
  • SSHServer: SSH サーバー
  • SSHUser: SSH ユーザー
  • SSHClientCert: 秘密鍵ファイルのパス

接続文字列形式では以下のようになります。User=admin;Password=adminpassword;Database=test;Server=mysql-server;Port=3306;UseSSH=true;SSHAuthMode=Public_Key;SSHClientCertType=PUBLIC_KEY_FILE;SSHPort=22;SSHServer=ssh-server;SSHUser=root;SSHClientCert=C:\Keys\key.pem;

Connect MySQL Data to Diagrams

Follow the steps below to use the Data Selector Wizard to import data into your diagram.

  1. Open Visio and click File -> New. Open the Brainstorming template.
  2. On the Data tab, click Link Data to Shapes.
  3. Select the ODBC option and select ODBC DSN.
  4. Select the DSN for MySQL, select the table you want to import, and finish the wizard. This article uses Orders as an example.

Link MySQL Entities to Shapes

Follow the steps below to create a simple diagram that shows how to create shapes from your data, one of the ways to link MySQL entities to shapes:

  1. Click Brainstorming Shapes and drag a main topic onto the drawing page. Enter Orders as the text of the main topic.
  2. Click Topic.
  3. Select a row in the External Data window and drag it onto the drawing page.
  4. Right-click the Topic shape and click Data -> Edit Data Graphic.
  5. Click New Item.
  6. In the Data Field menu, select a column. In the Displayed As menu, select how to display them.
  7. Drag a few other MySQL entities onto the drawing page and add association lines back to the main topic, Orders. New topics have the same configuration: Numeric columns displayed in data bars stand out in contrast to other Orders entities.

You can refresh your diagram from the Data tab, synchronizing your shapes with the external MySQL data.