FileMaker Pro からSage US Data への双方向連携

JDBC ドライバーのMySQL Remoting 機能を使用して、Mac またはWindows 用のFilemaker Pro にSage US data を連携します。

ここでは、CData JDBC Driver for Sage US を使用してFileMaker Pro の外部SQL ソース(ESS)機能と連携する方法を説明します。これにより、FileMaker Pro のレコードを他の運用データストアの関連レコードとリンクできます。

リモートのMySQL データベースとしてSage US にアクセスするには、MySQL Remoting 機能を使用します。CData JDBC Driver for Sage US は、MySQL のような従来のデータベースへの接続をサポートするが一般的なJDBC 接続はサポートしないFileMaker Pro のようなアプリケーションと連携するためにJDBC とMySQL の両方の規格を実装します。

FileMaker Pro のモードについて

There are two data access modes in FileMaker Pro:

  • Data Import: Sage US data is copied into a FileMaker Pro database and can be refreshed on demand.To streamline this solution, use the CData ODBC driver, as FileMaker Pro supports ODBC natively, but it does not support JDBC.

    To use this approach, see ODBC Sage US Integration in FileMaker Pro.

  • ESS:Instead of working with a local copy of the data, you can use the JDBC driver to create an external SQL source.The remote data can be modified in FileMaker Pro and tables can be used in the relationships graph like standard FileMaker Pro tables.

ESS 設定の概要

The JDBC driver is part of a data access chain.Compared to a native ODBC integration, FileMaker Pro integrations that use MySQL remoting have several additional components.This article shows how to link each of the following components with FileMaker Pro:

  1. The CData JDBC driver.
  2. The CData MySQL Remoting daemon (included with the driver).
  3. An ODBC driver for MySQL.

    On Windows, FileMaker Pro requires the official MySQL driver, the MySQL Connector\ODBC.

    On macOS, FileMaker Pro requires the Actual Technologies Open Databases ODBC driver.

  4. An ODBC driver manager.

    On Windows, the driver manager is built in.On macOS, you will need to install a driver manager before installing the ODBC driver; install the iODBC driver manager.

Remoting Daemon を起動

Follow the steps below to enable the MySQL Remoting feature:

  1. Open Terminal and change to the lib subfolder in the installation folder.

    $ cd "/Applications/CData/CData JDBC Driver for Sage US/lib"
  2. Start the MySQL daemon by specifying the configuration file or settings on the command line.The example below uses the included sample configuration file.

    $ java -jar cdata.jdbc.sage50us.jar -f "cdata.jdbc.sage50us.remoting.ini"

    The Application Id and Company Name connection string options are required to connect to Sage as a data source. You can obtain an Application Id by contacting Sage directly to request access to the Sage 50 SDK.

    Sage must be installed on the machine. The Sage.Peachtree.API.dll and Sage.Peachtree.API.Resolver.dll assemblies are required. These assemblies are installed with Sage in C:\Program Files\Sage\Peachtree\API\. Additionally, the Sage SDK requires .NET Framework 4.0 and is only compatible with 32-bit applications. To use the Sage SDK in Visual Studio, set the Platform Target property to "x86" in Project -> Properties -> Build.

    You must authorize the application to access company data: To authorize your application to access Sage, restart the Sage application, open the company you want to access, and connect with your application. You will then be prompted to set access permissions for the application in the resulting dialog.

    While the compiled executable will require authorization only once, during development you may need to follow this process to reauthorize a new build. To avoid restarting the Sage application when developing with Visual Studio, click Build -> Configuration Manager and uncheck "Build" for your project.

    See the help documentation for more information about the available connection properties and other configuration options for remoting.

DSN の作成

After connecting successfully to Sage US and starting the MySQL daemon, create a MySQL ODBC data source. When working with ODBC data sources, you specify connection properties in a DSN (data source name).

If you have not already obtained an ODBC driver and driver manager, refer to "Outlining the ESS Setup" to determine the components supported for your platform.

macOS

Follow the steps below to use the iODBC graphical administrator tool:

  1. Open iODBC by searching in the launchpad.
  2. On the System DSN tab, click Add and select Actual Open Source Databases.
  3. Provide the following information to complete the wizard:
    • Name:Enter the DSN.
    • Server:Enter 127.0.0.1 or the address of the machine where the MySQL daemon is running.
    • Port:Enter the port that the daemon is listening on.For example, 3306.
    • Database:Enter the name of a database specified in the config file for the daemon.For example, Sage50US.
  4. Click Test Connection and enter your credentials in the dialog.

Windows

You can use the built-in Microsoft ODBC Data Source Administrator to create the ODBC DSN.

  1. From the Control Panel, select Set Up Data Sources (ODBC).The ODBC Data Source Administrator is displayed.
  2. On the System DSN tab, click Add and select the MySQL ODBC driver.
  3. Provide the following information to complete the wizard:
    • Name:Enter the DSN.
    • Server:Enter 127.0.0.1 or the address of the machine where the MySQL daemon is running.
    • Port:Enter the port that the daemon is listening on.For example, 3306.
    • Database:Enter the name of a database specified in the config file for the daemon.For example, Sage50US.
  4. Click Test Connection and enter your credentials in the dialog.

Sage US シャドウテーブルの作成

Shadow tables exist in an external SQL source but can be used in much the same way as other tables in your FileMaker database; you can add them in the relationships graph, browse data, and create layouts on them.

  1. Click File -> Manage -> Database.
  2. On the Relationships tab of the resulting dialog, click the Add a Table button in the Table/Relationships section.
  3. In the Data Source menu, select Add ODBC Data Source and then select the DSN you created in the previous section.

After specifying the username and password for the DSN, you can add Sage US tables to the relationships graph. You can now scroll through, sort, edit, and summarize Sage US data by clicking View -> Browse Mode, just as you would a remote MySQL database.

 
 
ダウンロード