Informatica で、Sage US にJDBC データソースとして連携

標準のJDBC 接続プロセスを使用してInformatica にSage US データオブジェクトを作成します。JAR をコピーしてから接続します。

Informatica は、データを転送および変換するための強力で洗練された手段を提供します。CData JDBC Driver for Sage US を使用することで、Informatica の強力なデータ転送および操作機能とシームレスに統合されている業界で実証済みの標準に基づくドライバーにアクセスできます。このチュートリアルでは、Informatica PowerCenter でSage US data を転送および参照する方法を説明します。

ドライバーのデプロイ

To deploy the driver to the Informatica PowerCenter server, copy the CData JAR and .lic file, located in the lib subfolder in the installation directory, to the following folder: Informatica-installation-directory\services\shared\jars\thirdparty.

To work with Sage US data in the Developer tool, you will need to copy the CData JAR and .lic file, located in the lib subfolder in the installation directory, into the following folders:

  • Informatica-installation-directory\client\externaljdbcjars
  • Informatica-installation-directory\externaljdbcjars

JDBC 接続を作成

Follow the steps below to connect from Informatica Developer:

  1. In the Connection Explorer pane, right-click your domain and click Create a Connection.
  2. In the New Database Connection wizard that is displayed, enter a name and Id for the connection and in the Type menu select JDBC.
  3. In the JDBC Driver Class Name property, enter: cdata.jdbc.sage50us.Sage50USDriver
  4. In the Connection String property, enter the JDBC URL, using the connection properties for Sage US.

    The Application Id and Company Name connection string options are required to connect to Sage as a data source. You can obtain an Application Id by contacting Sage directly to request access to the Sage 50 SDK.

    Sage must be installed on the machine. The Sage.Peachtree.API.dll and Sage.Peachtree.API.Resolver.dll assemblies are required. These assemblies are installed with Sage in C:\Program Files\Sage\Peachtree\API\. Additionally, the Sage SDK requires .NET Framework 4.0 and is only compatible with 32-bit applications. To use the Sage SDK in Visual Studio, set the Platform Target property to "x86" in Project -> Properties -> Build.

    You must authorize the application to access company data: To authorize your application to access Sage, restart the Sage application, open the company you want to access, and connect with your application. You will then be prompted to set access permissions for the application in the resulting dialog.

    While the compiled executable will require authorization only once, during development you may need to follow this process to reauthorize a new build. To avoid restarting the Sage application when developing with Visual Studio, click Build -> Configuration Manager and uncheck "Build" for your project.

    ビルトイン接続文字列デザイナー

    For assistance in constructing the JDBC URL, use the connection string designer built into the Sage US JDBC Driver.Either double-click the JAR file or execute the jar file from the command-line.

    java -jar cdata.jdbc.sage50us.jar

    Fill in the connection properties and copy the connection string to the clipboard.

    A typical connection string is below:

    jdbc:sage50us:ApplicationId=8dfafu4V4ODmh1fM0xx;CompanyName=Bellwether Garden Supply - Premium;

Sage US テーブルを閲覧

After you have added the driver JAR to the classpath and created a JDBC connection, you can now access Sage US entities in Informatica.Follow the steps below to connect to Sage US and browse Sage US tables:

  1. Connect to your repository.
  2. In the Connection Explorer, right-click the connection and click Connect.
  3. Clear the Show Default Schema Only option.

You can now browse Sage US tables in the Data Viewer:Right-click the node for the table and then click Open.On the Data Viewer view, click Run.

Sage US データオブジェクトを作成

Follow the steps below to add Sage US tables to your project:

  1. Select tables in Sage US, then right-click a table in Sage US, and click Add to Project.
  2. In the resulting dialog, select the option to create a data object for each resource.
  3. In the Select Location dialog, select your project.

    マッピングを作成

    Follow the steps below to add the Sage US source to a mapping:

    1. In the Object Explorer, right-click your project and then click New -> Mapping.
    2. Expand the node for the Sage US connection and then drag the data object for the table onto the editor.
    3. In the dialog that appears, select the Read option.

    Follow the steps below to map Sage US columns to a flat file:

    1. In the Object Explorer, right-click your project and then click New -> Data Object.
    2. Select Flat File Data Object -> Create as Empty -> Fixed Width.
    3. In the properties for the Sage US object, select the rows you want, right-click, and then click copy.Paste the rows into the flat file properties.
    4. Drag the flat file data object onto the mapping.In the dialog that appears, select the Write option.
    5. Click and drag to connect columns.

    To transfer Sage US data, right-click in the workspace and then click Run Mapping.

 
 
ダウンロード