Enable the CData JDBC Driver for Sage US in KNIME

Use standard data access components in KNIME to create charts and reports with Sage US data.

One of the strengths of the CData JDBC Driver for Sage US is its cross-platform support, enabling integration with major BI tools. Follow the procedure below to access Sage US data in KNIME and to create a chart from Sage US data using the report designer.

Define a New JDBC Connection to Sage US Data

  1. If you have not already done so, install the Report Designer extension: Click File -> Install KNIME Extensions, and filter on "Report".
  2. In a new workflow, click File -> Preferences and expand the KNIME -> Database Driver nodes to add cdata.jdbc.sage50us.jar. The driver JAR is located in the lib subfolder of the installation directory.
  3. In the Node Repository view, expand the Database node and drag a Database Reader onto the workflow editor.
  4. Double-click the Database Reader and set the following properties:

    • Database Driver: In the menu, select the CData JDBC driver.
    • Database URL: Enter the connection properties. The JDBC URL begins with jdbc:sage50us: and is followed by a semicolon-separated list of connection properties.

      The Application Id and Company Name connection string options are required to connect to Sage as a data source. You can obtain an Application Id by contacting Sage directly to request access to the Sage 50 SDK.

      Sage must be installed on the machine. The Sage.Peachtree.API.dll and Sage.Peachtree.API.Resolver.dll assemblies are required. These assemblies are installed with Sage in C:\Program Files\Sage\Peachtree\API\. Additionally, the Sage SDK requires .NET Framework 4.0 and is only compatible with 32-bit applications. To use the Sage SDK in Visual Studio, set the Platform Target property to "x86" in Project -> Properties -> Build.

      You must authorize the application to access company data: To authorize your application to access Sage, restart the Sage application, open the company you want to access, and connect with your application. You will then be prompted to set access permissions for the application in the resulting dialog.

      While the compiled executable will require authorization only once, during development you may need to follow this process to reauthorize a new build. To avoid restarting the Sage application when developing with Visual Studio, click Build -> Configuration Manager and uncheck "Build" for your project.

      A typical JDBC URL is below. jdbc:sage50us:ApplicationId=8dfafu4V4ODmh1fM0xx;CompanyName=Bellwether Garden Supply - Premium;

    • User Name: The username used to authenticate.
    • Password: The password used to authenticate.
    • SQL Statement: Enter an SQL query in the SQL Statement box or double-click a table. This article uses the query below to create a chart: SELECT Name, LastInvoiceAmount FROM Customer
  5. Test the connection by clicking Fetch Metadata.

  6. Connect the Database Reader to a Data to Report node to supply the dataset to a range of data visualization controls. Click Execute and then click Edit Report at the top of the workflow to open the report designer perspective.
  7. You can now generate reports based on live data. To create a chart, drag the chart control from the palette to the report designer. In the resulting wizard, you can use the filtering and aggregation controls available in KNIME.
 
 
ダウンロード