Pentaho Report Designer にSage US Data を繋いでみた

Pentaho BI ツールでSage US data のレポートを作成。



CData JDBC Driver for Sage US data はダッシュボードや帳票ツールからライブデータへのアクセスを可能にします。この記事では、Sage US data をJDBC データソースとして接続する方法と、Pentaho でSage US data を元に帳票を作成する方法を説明します。

接続と帳票の作成

  1. インストールディレクトリの[lib]サブフォルダ内のJAR ファイルをコピーし、Pentaho のディレクトリ内の\Report-Designer\lib\jdbc\ フォルダに配置します。
  2. \Report-Designer\ フォルダのreport-designer.bat ファイルを起動し、Report-Designer UI を開きます。
  3. 以下の手順でドライバーを新しいデータソースに設定します。[Data]>[Add Data Source]>[Advanced]>[JDBC (Custom)]とクリックし、新しいSage US 接続を作成します。ダイアログが表示されたら、次のように接続プロパティを設定します。

    • Custom Connection URL property:JDBC URL を入力。初めに以下を入力し jdbc:sage50us: 次にセミコロン区切りで接続プロパティを入力します。

      The Application Id and Company Name connection string options are required to connect to Sage as a data source. You can obtain an Application Id by contacting Sage directly to request access to the Sage 50 SDK.

      Sage must be installed on the machine. The Sage.Peachtree.API.dll and Sage.Peachtree.API.Resolver.dll assemblies are required. These assemblies are installed with Sage in C:\Program Files\Sage\Peachtree\API\. Additionally, the Sage SDK requires .NET Framework 4.0 and is only compatible with 32-bit applications. To use the Sage SDK in Visual Studio, set the Platform Target property to "x86" in Project -> Properties -> Build.

      You must authorize the application to access company data: To authorize your application to access Sage, restart the Sage application, open the company you want to access, and connect with your application. You will then be prompted to set access permissions for the application in the resulting dialog.

      While the compiled executable will require authorization only once, during development you may need to follow this process to reauthorize a new build. To avoid restarting the Sage application when developing with Visual Studio, click Build -> Configuration Manager and uncheck "Build" for your project.

      以下は一般的なJDBC URL です:

      jdbc:sage50us:ApplicationId=8dfafu4V4ODmh1fM0xx;CompanyName=Bellwether Garden Supply - Premium;
    • Custom Driver Class Name:cdata.jdbc.sage50us.Sage50USDriver と入力。
    • User Name:認証するユーザーネーム。
    • Password:認証するパスワード。

レポートに Sage US Data を追加

これで、Sage US data の帳票を作成する準備が整いました。

  1. 帳票にSage US データソースを追加します:[Data]>[Add Data Source]>[JDBC]をクリックし、データソースを選択します。

  2. クエリを設定します。この記事では次を使います:

    SELECT Name, LastInvoiceAmount FROM Customer
  3. 帳票にチャートをドラッグし、ダブルクリックしてチャートを編集します。帳票を実行して、チャートを表示します。このクエリ結果を使って、Customer テーブルのシンプルなチャートを作成することができます。
  4. 帳票を実行して、チャートを見てみましょう。
 
 
ダウンロード