Connect to Sage US Data in RazorSQL

Connect to Sage US from wizards and query Sage US data from the GUI in the RazorSQL database management tool.

The CData JDBC Driver for Sage US enables standards-based access from third-party tools, from wizards in IDEs to data management and analysis tools. This article shows how to connect to Sage US using wizards in RazorSQL.

Create a JDBC Data Source for Sage US Data

  1. Open the RazorSQL application and, in the Connections menu, select Add Connection Profile -> Other -> JDBC.
  2. In the Connection Wizard that appears, set the following properties:
    • Driver Location: Set this property to the path to the lib subfolder in the installation directory.
    • Driver Class: Set the driver class to cdata.jdbc.sage50us.Sage50USDriver.
    • Username: Enter the username. (This property can also be set in the JDBC URL.)
    • Password: Enter the password. (This property can also be set in the JDBC URL.)
    • JDBC URL: Enter connection parameters. The JDBC URL begins with jdbc:sage50us: and is followed by a semicolon-separated list of connection properties.

      The Application Id and Company Name connection string options are required to connect to Sage as a data source. You can obtain an Application Id by contacting Sage directly to request access to the Sage 50 SDK.

      Sage must be installed on the machine. The Sage.Peachtree.API.dll and Sage.Peachtree.API.Resolver.dll assemblies are required. These assemblies are installed with Sage in C:\Program Files\Sage\Peachtree\API\. Additionally, the Sage SDK requires .NET Framework 4.0 and is only compatible with 32-bit applications. To use the Sage SDK in Visual Studio, set the Platform Target property to "x86" in Project -> Properties -> Build.

      You must authorize the application to access company data: To authorize your application to access Sage, restart the Sage application, open the company you want to access, and connect with your application. You will then be prompted to set access permissions for the application in the resulting dialog.

      While the compiled executable will require authorization only once, during development you may need to follow this process to reauthorize a new build. To avoid restarting the Sage application when developing with Visual Studio, click Build -> Configuration Manager and uncheck "Build" for your project.

      A typical JDBC URL is the following:

      jdbc:sage50us:ApplicationId=8dfafu4V4ODmh1fM0xx;CompanyName=Bellwether Garden Supply - Premium;
  3. The Application Id and Company Name connection string options are required to connect to Sage as a data source. You can obtain an Application Id by contacting Sage directly to request access to the Sage 50 SDK.

    Sage must be installed on the machine. The Sage.Peachtree.API.dll and Sage.Peachtree.API.Resolver.dll assemblies are required. These assemblies are installed with Sage in C:\Program Files\Sage\Peachtree\API\. Additionally, the Sage SDK requires .NET Framework 4.0 and is only compatible with 32-bit applications. To use the Sage SDK in Visual Studio, set the Platform Target property to "x86" in Project -> Properties -> Build.

    You must authorize the application to access company data: To authorize your application to access Sage, restart the Sage application, open the company you want to access, and connect with your application. You will then be prompted to set access permissions for the application in the resulting dialog.

    While the compiled executable will require authorization only once, during development you may need to follow this process to reauthorize a new build. To avoid restarting the Sage application when developing with Visual Studio, click Build -> Configuration Manager and uncheck "Build" for your project.

Query Sage US Data and Select Tables

After establishing a connection, the wizard will close and the connection will be available in the connections panel. You can then query the tables.

 
 
ダウンロード