Create an SAP BusinessObjects Universe on the CData JDBC Driver for Sage US

Provide connectivity to Sage US data through an SAP BusinessObjects universe.

This article shows how to use the CData JDBC Driver for Sage US to connect to Sage US from SAP BusinessObjects Business Intelligence applications. You will use the Information Design Tool to analyze Sage US data and create a universe on the CData JDBC Driver for Sage US. You will then connect to the universe from Web Intelligence.

Create the JDBC Connection to Sage US

Follow the steps below to create a connection to the Sage US JDBC data source in the Information Design Tool.

  1. Copy the CData JAR and .lic file into the following subfolder in the installation directory for BusinessObjects: dataAccess\connectionServer\jdbc\drivers\jdbc. The CData JAR is located in the lib subfolder of the installation directory.
  2. Right-click your project and click New -> New Relational Connection.
  3. In the wizard that results, click Generic -> Generic JDBC datasource -> JDBC Drivers.
  4. On the next page of the wizard enter the connection details.
  5. On the next page, set the Authentication Mode option to "Use specified username and password". Enter the username, password, and JDBC URL. The JDBC URL begins with jdbc:sage50us: and is followed by a semicolon-separated list of connection properties.

    The Application Id and Company Name connection string options are required to connect to Sage as a data source. You can obtain an Application Id by contacting Sage directly to request access to the Sage 50 SDK.

    Sage must be installed on the machine. The Sage.Peachtree.API.dll and Sage.Peachtree.API.Resolver.dll assemblies are required. These assemblies are installed with Sage in C:\Program Files\Sage\Peachtree\API\. Additionally, the Sage SDK requires .NET Framework 4.0 and is only compatible with 32-bit applications. To use the Sage SDK in Visual Studio, set the Platform Target property to "x86" in Project -> Properties -> Build.

    You must authorize the application to access company data: To authorize your application to access Sage, restart the Sage application, open the company you want to access, and connect with your application. You will then be prompted to set access permissions for the application in the resulting dialog.

    While the compiled executable will require authorization only once, during development you may need to follow this process to reauthorize a new build. To avoid restarting the Sage application when developing with Visual Studio, click Build -> Configuration Manager and uncheck "Build" for your project.

    A typical JDBC URL is below:

    jdbc:sage50us:ApplicationId=8dfafu4V4ODmh1fM0xx;CompanyName=Bellwether Garden Supply - Premium;
  6. Enter the driver class: cdata.jdbc.sage50us.Sage50USDriver
  7. Finish the wizard with the default values for connection pooling and custom parameters.

Analyze Sage US Data in the Information Design Tool

You can use the JDBC connection to analyze Sage US data in the Information Design Tool.

  1. In the Local Projects view, double-click the connection (the .cnx file) to open the Sage US data source.
  2. On the Show Values tab, you can load table data and enter SQL queries. To view table data, expand the node for the table, right-click the table, and click Show Values. Values will be displayed in the Raw Data tab.
  3. On the Analysis tab, you can then analyze data by dragging and dropping columns onto the axes of a chart.

Publish the Local Connection

To publish the universe to the CMS, you additionally need to publish the connection.

  1. In the Local Projects view, right-click the connection and click Publish Connection to a Repository.
  2. Enter the host and port of the repository and connection credentials.
  3. Select the folder where the connection will be published.
  4. In the success dialog that results, click Yes to create a connection shortcut.

Create a Universe on the JDBC Driver for Sage US

You can follow the steps below to create a universe on the JDBC driver. The universe in this example will be published to a repository, so it uses the published connection created in the previous step.

  1. In the Information Design Tool, click File->New Universe.
  2. Select your project.
  3. Select the option to create the universe on a relational data source.
  4. Select the shortcut to the published connection.
  5. Enter a name for the Data Foundation.
  6. Import tables and columns that you want to access as objects.
  7. Enter a name for the Business Layer.

Publish the Universe

You can follow the steps below to publish the universe to the CMS.

  1. In the Local Projects view, right-click the business layer and click Publish -> To a Repository.
  2. In the Publish Universe dialog, enter any integrity checks before importing.
  3. Select or create a folder on the repository where the universe will be published.

Query Sage US Data in Web Intelligence

You can use the published universe to connect to Sage US in Web Intelligence.

  1. Copy the cdata.jdbc.sage50us.lic file to the following subfolder in the BusinessObjects installation directory: \dataAccess\connectionServer\jdbc\drivers\jdbc. The license file is located in the lib subfolder of the installation directory.
  2. Open Web Intelligence from the BusinessObjects launchpad and create a new document.
  3. Select the Universe option for the data source.
  4. Select the Sage US universe. This opens a Query Panel. Drag objects to the Result Objects pane to use them in the query.
 
 
ダウンロード