リアルタイム Sage US Data に連携するレポートをPower BI で作成

Power BI connector を使ってSage US Data をビジュアライズ

CData Power BI Connectors は、セルフサービスBI であるMicrosoft Power BI へのデータソースを拡充します。 CData Power BI Connector は、Power BI レポートにリアルタイムSage US data をデータ連携します。 ダッシュボードでSage US data をモニタリングし、スケジューラーやリアルタイムででデータを更新することで、リアルタイムSage US data データが反映されるようにできます。 ここでは、Power BI Connector を使用してMicrosoft Power BI Desktop でSage US data のビジュアライゼーションを作成する方法について詳しく説明します。

PowerBI.com へのSage US data レポートの発行の詳細については、弊社のナレッジベースをご参照ください。

コラボラティブ処理

The CData Power BI Connectors offer unmatched performance for interacting with live Sage US data in Power BI due to optimized data processing built into the connector.When you issue complex SQL queries from Power BI to Sage US, the connector pushes supported SQL operations, like filters and aggregations, directly to Sage US and utilizes the embedded SQL Engine to process unsupported operations (often SQL functions and JOIN operations) client-side.With built-in dynamic metadata querying, you can visualize and analyze Sage US data using native Power BI data types.

Power BI データソースとしてSage US を連携

If you have not already, first provide authentication and any necessary connection properties in a DSN (data source name).This is the last step of installing the connector.

You can use the Microsoft ODBC Data Source Administrator to create and configure the DSN:From the Start menu, enter "ODBC Data Sources" and select the CData PowerBI REST DSN.Ensure that you run the version of the ODBC Administrator that corresponds to the bitness of your Power BI Desktop installation (32-bit or 64-bit).You can also use run the ConfigureODBC.exe tool located in the installation folder for the connector.

The Application Id and Company Name connection string options are required to connect to Sage as a data source. You can obtain an Application Id by contacting Sage directly to request access to the Sage 50 SDK.

Sage must be installed on the machine. The Sage.Peachtree.API.dll and Sage.Peachtree.API.Resolver.dll assemblies are required. These assemblies are installed with Sage in C:\Program Files\Sage\Peachtree\API\. Additionally, the Sage SDK requires .NET Framework 4.0 and is only compatible with 32-bit applications. To use the Sage SDK in Visual Studio, set the Platform Target property to "x86" in Project -> Properties -> Build.

You must authorize the application to access company data: To authorize your application to access Sage, restart the Sage application, open the company you want to access, and connect with your application. You will then be prompted to set access permissions for the application in the resulting dialog.

While the compiled executable will require authorization only once, during development you may need to follow this process to reauthorize a new build. To avoid restarting the Sage application when developing with Visual Studio, click Build -> Configuration Manager and uncheck "Build" for your project.

Sage US テーブルをクエリ

Follow the steps below to build a query to pull Sage US data into the report:

  1. Open Power BI Desktop and click Get Data -> Other -> CData Sage50US.
  2. Select CData PowerBI Sage US in the Data Source Name menu and select a data connectivity mode:
    Select Import if you want to import a copy of the data into your project.You can refresh this data on demand.
    Select DirectQuery if you want to work with the remote data.
  3. Select tables in the Navigator dialog.
  4. In the Query Editor, you can customize your dataset by filtering, sorting, and summarizing Sage US columns.Click Edit to open the query editor.Right-click a row to filter the rows.Right-click a column header to perform actions like the following:

    • Change column data types
    • Remove a column
    • Group by columns

    Power BI detects each column's data type from the Sage US metadata retrieved by the connector.

    Power BI records your modifications to the query in the Applied Steps section, adjusting the underlying data retrieval query that is executed to the remote Sage US data. When you click Close and Apply, Power BI executes the data retrieval query.

    Otherwise, click Load to pull the data into Power BI.

データビジュアライゼーションを作成

After pulling the data into Power BI, you can create data visualizations in the Report view by dragging fields from the Fields pane onto the canvas.Follow the steps below to create a pie chart:

  1. Select the pie chart icon in the Visualizations pane.
  2. Select a dimension in the Fields pane: for example, Name.
  3. Select a measure in the Fields pane: for example, LastInvoiceAmount.

You can change sort options by clicking the ellipsis (...) button for the chart.Options to select the sort column and change the sort order are displayed.

You can use both highlighting and filtering to focus on data.Filtering removes unfocused data from visualizations; highlighting dims unfocused data. You can highlight fields by clicking them:

You can apply filters at the page level, at the report level, or to a single visualization by dragging fields onto the Filters pane.To filter on the field's value, select one of the values that are displayed in the Filters pane.

Click Refresh to synchronize your report with any changes to the data.

At this point, you will have a Power BI report built on top of live Sage US data.Learn more about the CData Power BI Connectors for Sage US and download a free trial from the Sage US Power BI Connector page.Let our Support Team know if you have any questions.

 
 
ダウンロード