Visio Shapes とSage Cloud Accounting Data を連携

Visio master shapes での変更を自動的にSage Cloud Accounting data に更新。

Automate the process of entering data into Visio diagrams and keeping your diagrams up to date with the CData ODBC Driver for Sage Cloud Accounting. The driver surfaces Sage Cloud Accounting data as an ODBC data source that can be accessed by applications with built-in ODBC support like Microsoft Office. This article shows how to create a simple diagram to start brainstorming about Visio projects linked to Sage Cloud Accounting data.

Connect to Sage Cloud Accounting as an ODBC Data Source

If you have not already, first specify connection properties in an ODBC DSN (data source name). This is the last step of the driver installation. You can use the Microsoft ODBC Data Source Administrator to create and configure ODBC DSNs.

You can connect to Sage Business Cloud Accounting using the embedded OAuth connectivity. When you connect, the OAuth endpoint opens in your browser. Log in and grant permissions to complete the OAuth process. See the OAuth section in the online Help documentation for more information on other OAuth authentication flows.

Connect Sage Cloud Accounting Data to Diagrams

Follow the steps below to use the Data Selector Wizard to import data into your diagram.

  1. Open Visio and click File -> New. Open the Brainstorming template.
  2. On the Data tab, click Link Data to Shapes.
  3. Select the ODBC option and select ODBC DSN.
  4. Select the DSN for Sage Cloud Accounting, select the table you want to import, and finish the wizard. This article uses SalesInvoices as an example.

Link Sage Cloud Accounting Entities to Shapes

Follow the steps below to create a simple diagram that shows how to create shapes from your data, one of the ways to link Sage Cloud Accounting entities to shapes:

  1. Click Brainstorming Shapes and drag a main topic onto the drawing page. Enter SalesInvoices as the text of the main topic.
  2. Click Topic.
  3. Select a row in the External Data window and drag it onto the drawing page.
  4. Right-click the Topic shape and click Data -> Edit Data Graphic.
  5. Click New Item.
  6. In the Data Field menu, select a column. In the Displayed As menu, select how to display them.
  7. Drag a few other Sage Cloud Accounting entities onto the drawing page and add association lines back to the main topic, SalesInvoices. New topics have the same configuration: Numeric columns displayed in data bars stand out in contrast to other SalesInvoices entities.

You can refresh your diagram from the Data tab, synchronizing your shapes with the external Sage Cloud Accounting data.

 
 
ダウンロード