Ready to get started?

Learn more about the CData ODBC Driver for ServiceNow or download a free trial:

Download Now

Visio Shapes とServiceNow Data を連携

Visio master shapes での変更を自動的にServiceNow data に更新。

Automate the process of entering data into Visio diagrams and keeping your diagrams up to date with the CData ODBC Driver for ServiceNow. The driver surfaces ServiceNow data as an ODBC data source that can be accessed by applications with built-in ODBC support like Microsoft Office. This article shows how to create a simple diagram to start brainstorming about Visio projects linked to ServiceNow data.

Connect to ServiceNow as an ODBC Data Source

If you have not already, first specify connection properties in an ODBC DSN (data source name). This is the last step of the driver installation. You can use the Microsoft ODBC Data Source Administrator to create and configure ODBC DSNs.

ServiceNow uses the OAuth 2.0 authentication standard. To authenticate using OAuth, you will need to register an OAuth app with ServiceNow to obtain the OAuthClientId and OAuthClientSecret connection properties. In addition to the OAuth values, you will need to specify the Instance, Username, and Password connection properties.

See the "Getting Started" chapter in the help documentation for a guide on connecting to ServiceNow.

Connect ServiceNow Data to Diagrams

Follow the steps below to use the Data Selector Wizard to import data into your diagram.

  1. Open Visio and click File -> New. Open the Brainstorming template.
  2. On the Data tab, click Link Data to Shapes.
  3. Select the ODBC option and select ODBC DSN.
  4. Select the DSN for ServiceNow, select the table you want to import, and finish the wizard. This article uses incident as an example.

Link ServiceNow Entities to Shapes

Follow the steps below to create a simple diagram that shows how to create shapes from your data, one of the ways to link ServiceNow entities to shapes:

  1. Click Brainstorming Shapes and drag a main topic onto the drawing page. Enter incident as the text of the main topic.
  2. Click Topic.
  3. Select a row in the External Data window and drag it onto the drawing page.
  4. Right-click the Topic shape and click Data -> Edit Data Graphic.
  5. Click New Item.
  6. In the Data Field menu, select a column. In the Displayed As menu, select how to display them.
  7. Drag a few other ServiceNow entities onto the drawing page and add association lines back to the main topic, incident. New topics have the same configuration: Numeric columns displayed in data bars stand out in contrast to other incident entities.

You can refresh your diagram from the Data tab, synchronizing your shapes with the external ServiceNow data.

 
 
ダウンロード