Ready to get started?

Learn more about the CData ODBC Driver for YouTube Analytics or download a free trial:

Download Now

Visio Shapes とYouTube Analytics Data を連携

Visio master shapes での変更を自動的にYouTube Analytics data に更新。

Automate the process of entering data into Visio diagrams and keeping your diagrams up to date with the CData ODBC Driver for YouTube Analytics. The driver surfaces YouTube Analytics data as an ODBC data source that can be accessed by applications with built-in ODBC support like Microsoft Office. This article shows how to create a simple diagram to start brainstorming about Visio projects linked to YouTube Analytics data.

Connect to YouTube Analytics as an ODBC Data Source

If you have not already, first specify connection properties in an ODBC DSN (data source name). This is the last step of the driver installation. You can use the Microsoft ODBC Data Source Administrator to create and configure ODBC DSNs.

YouTube Analytics uses the OAuth authentication standard. You can use the embedded CData OAuth credentials or you can register an application with Google to obtain your own.

In addition to the OAuth values, to access YouTube Analytics data set ChannelId to the Id of a YouTube channel. You can obtain the channel Id in the advanced account settings for your channel. If not specified, the channel of the currently authenticated user will be used.

If you want to generate content owner reports, specify the ContentOwnerId property. This is the Id of the copyright holder for content in YouTube's rights management system. The content owner is the person or organization that claims videos and sets their monetization policy.

Connect YouTube Analytics Data to Diagrams

Follow the steps below to use the Data Selector Wizard to import data into your diagram.

  1. Open Visio and click File -> New. Open the Brainstorming template.
  2. On the Data tab, click Link Data to Shapes.
  3. Select the ODBC option and select ODBC DSN.
  4. Select the DSN for YouTube Analytics, select the table you want to import, and finish the wizard. This article uses Groups as an example.

Link YouTube Analytics Entities to Shapes

Follow the steps below to create a simple diagram that shows how to create shapes from your data, one of the ways to link YouTube Analytics entities to shapes:

  1. Click Brainstorming Shapes and drag a main topic onto the drawing page. Enter Groups as the text of the main topic.
  2. Click Topic.
  3. Select a row in the External Data window and drag it onto the drawing page.
  4. Right-click the Topic shape and click Data -> Edit Data Graphic.
  5. Click New Item.
  6. In the Data Field menu, select a column. In the Displayed As menu, select how to display them.
  7. Drag a few other YouTube Analytics entities onto the drawing page and add association lines back to the main topic, Groups. New topics have the same configuration: Numeric columns displayed in data bars stand out in contrast to other Groups entities.

You can refresh your diagram from the Data tab, synchronizing your shapes with the external YouTube Analytics data.

 
 
ダウンロード