Visio Shapes とBusiness b-ridge Data を連携

詳細情報をご希望ですか?

無償トライアル:

ダウンロードへ

製品の詳細情報へ:

Business b-ridge ODBC Driver

Business b-ridgeODBC Driver を使って、ODBC 接続をサポートするあらゆるアプリケーション・ツールからBusiness b-ridge にデータ連携。

Business b-ridge データにデータベースと同感覚でアクセスして、多様なデータに使い慣れたODBC インターフェースで双方向連携。



Visio master shapes での変更を自動的にBusiness b-ridge data に更新。

Automate the process of entering data into Visio diagrams and keeping your diagrams up to date with the CData ODBC Driver for Business b-ridge. The driver surfaces Business b-ridge data as an ODBC data source that can be accessed by applications with built-in ODBC support like Microsoft Office. This article shows how to create a simple diagram to start brainstorming about Visio projects linked to Business b-ridge data.

Connect to Business b-ridge as an ODBC Data Source

If you have not already, first specify connection properties in an ODBC DSN (data source name). This is the last step of the driver installation. You can use the Microsoft ODBC Data Source Administrator to create and configure ODBC DSNs.

When connecting to Business b-ridge, CompanyKey, ProjectKey, and SubscriptionKey are required.

To obtain the SubscriptionKey, follow the steps below:

  • Log in to Business b-ridge API Protal and go to "Profile" in the "Your name" menu.
  • In your subscription section click "Main Key" to retrieve their respective values.

Authenticate to Business b-ridge Account

Set the following connection properties to connect:

  • CompanyKey: Set the Business b-ridge Company Key of the connection destination.
  • ProjectKey: Set the Business b-ridge Project Key of the connection destination.
  • SubscriptionKey: Set the value "Subscription Key".

Connect Business b-ridge Data to Diagrams

Follow the steps below to use the Data Selector Wizard to import data into your diagram.

  1. Open Visio and click File -> New. Open the Brainstorming template.
  2. On the Data tab, click Link Data to Shapes.
  3. Select the ODBC option and select ODBC DSN.
  4. Select the DSN for Business b-ridge, select the table you want to import, and finish the wizard. This article uses CDATA as an example.

Link Business b-ridge Entities to Shapes

Follow the steps below to create a simple diagram that shows how to create shapes from your data, one of the ways to link Business b-ridge entities to shapes:

  1. Click Brainstorming Shapes and drag a main topic onto the drawing page. Enter CDATA as the text of the main topic.
  2. Click Topic.
  3. Select a row in the External Data window and drag it onto the drawing page.
  4. Right-click the Topic shape and click Data -> Edit Data Graphic.
  5. Click New Item.
  6. In the Data Field menu, select a column. In the Displayed As menu, select how to display them.
  7. Drag a few other Business b-ridge entities onto the drawing page and add association lines back to the main topic, CDATA. New topics have the same configuration: Numeric columns displayed in data bars stand out in contrast to other CDATA entities.

You can refresh your diagram from the Data tab, synchronizing your shapes with the external Business b-ridge data.