今すぐお試しください!

製品の詳細CData ODBC Driver for DataRobot を確認して、無償評価版をダウンロード:

今すぐダウンロード

Visio Shapes とDataRobot Data を連携

Visio master shapes での変更を自動的にDataRobot data に更新。

Automate the process of entering data into Visio diagrams and keeping your diagrams up to date with the CData ODBC Driver for DataRobot. The driver surfaces DataRobot data as an ODBC data source that can be accessed by applications with built-in ODBC support like Microsoft Office. This article shows how to create a simple diagram to start brainstorming about Visio projects linked to DataRobot data.

Connect to DataRobot as an ODBC Data Source

If you have not already, first specify connection properties in an ODBC DSN (data source name). This is the last step of the driver installation. You can use the Microsoft ODBC Data Source Administrator to create and configure ODBC DSNs.

DataRobot への接続には、User およびPassword をログインクレデンシャルに設定し、PredictionInstance を指定します。さらに、すでに取得している場合は、APIKey 接続プロパティをAPI Token に設定します。DataRobot にCloud Prediction インスタンスを使用している場合は、DataRobotKey も提供する必要があります。 APIKey を取得するには、以下の手順に従ってください。

User、DataRobotKey、APIKey はDataRobot アカウントのクレデンシャルです。

ProjectID、DataFile、ModelId はDataRobot 内のプロジェクト、データセット、モデルタイプです。

Connect DataRobot Data to Diagrams

Follow the steps below to use the Data Selector Wizard to import data into your diagram.

  1. Open Visio and click File -> New. Open the Brainstorming template.
  2. On the Data tab, click Link Data to Shapes.
  3. Select the ODBC option and select ODBC DSN.
  4. Select the DSN for DataRobot, select the table you want to import, and finish the wizard. This article uses Predictions as an example.

Link DataRobot Entities to Shapes

Follow the steps below to create a simple diagram that shows how to create shapes from your data, one of the ways to link DataRobot entities to shapes:

  1. Click Brainstorming Shapes and drag a main topic onto the drawing page. Enter Predictions as the text of the main topic.
  2. Click Topic.
  3. Select a row in the External Data window and drag it onto the drawing page.
  4. Right-click the Topic shape and click Data -> Edit Data Graphic.
  5. Click New Item.
  6. In the Data Field menu, select a column. In the Displayed As menu, select how to display them.
  7. Drag a few other DataRobot entities onto the drawing page and add association lines back to the main topic, Predictions. New topics have the same configuration: Numeric columns displayed in data bars stand out in contrast to other Predictions entities.

You can refresh your diagram from the Data tab, synchronizing your shapes with the external DataRobot data.

 
 
ダウンロード