Power View でのDocuSign データのインポートとビジュアライズ

詳細情報をご希望ですか?

無償トライアル:

ダウンロードへ

製品の詳細情報へ:

DocuSign ODBC Driver

DocuSign ODBC Driver を使って、ODBC 接続をサポートするあらゆるアプリケーション・ツールからDocuSign データに連携。

DocuSign にデータベースのようにアクセス - Accounts、Envelopes、Folders にODBC インターフェースで接続。



Excel でDocuSign データを使ったデータビジュアライゼーションを作成します。

Excel に組み込まれているODBC サポートを使用して、DocuSign データを使用したPower View レポートを素早く作成できます。この記事では、Data リボンからアクセスできるData Connection Wizard を使用して、DocuSign をPower View レポートにインポートする方法を説明します。

ODBC Data Source としてDocuSign に接続

未指定の場合は、初めにODBC DSN (data source name) で接続プロパティを指定します。ドライバーのインストールの最後にアドミニストレーターが開きます。Microsoft ODBC Data Source Administrator を使用して、ODBC DSN を作成および構成できます。

DocuSign への接続には以下の接続プロパティを設定します:

  • UseSandbox: UseSandbox は現在のユーザーアカウントがサンドボックスかそうでないかを示します。デフォルトはfalse です。サンドボックスアカウントがある場合はTrue に設定します。
  • AccountId (optional): 認証が成功すると自動的に設定されます。 または、複数のAccount Id にアクセスできる場合は、接続文字列で手動で設定できます。アカウントId を取得するには、UserInfo ビューをクエリします。

DocuSign への認証

DocuSign はOAuth 認証標準を利用しています。OAuth を使って認証するには、アプリケーションを作成してOAuthClientId、OAuthClientSecret、およびCallbackURL 接続プロパティを取得しなければなりません。認証方法については、ヘルプドキュメントの「OAuth 認証の使用」を参照してください。

DSN を構成する際に、Max Rows プロパティを定めることも可能です。これによって返される行数が制限されるので、ビジュアライゼーション・レポートのデザイン時のパフォーマンスを向上させるのに役立ちます。

Data Connection Wizard で接続

以下のステップに従って、Excel のData Connection Wizard からDSN に接続します。

  1. [Data]タブで、[From Other Sources]->[From Data Connection Wizard]とクリックします。
  2. [Data Connection Wizard]で[ODBC DSN]オプションを選択します。
  3. リストから[ODBC DSN for DocuSign]を選択します。
  4. 操作するテーブルを選択します。

    複数のテーブルをインポートする場合は、[Connect to a specific table]オプションの選択を解除します。データソースに接続したら、複数のテーブルを選択できます。[Finish]をクリックして[Data Connection Wizard]を閉じた後、[Select Table]ダイアログで[Enable selection of multiple tables]オプションを選択します。

  5. [Import Data]ダイアログで、データのインポート先を選択します。例えば、[Table]オプションと[Existing worksheet]オプションを選択します。次に、結果を出力するワークシートのセルをクリックします。
  6. [Insert]->[Power View]とクリックして新しいPower View レポートを作成します。

テーブルの作成

テーブルは、チャートやその他のデータの表現の開始点です。テーブルを作成するには、フィールドリストでカラムを選択します。テーブル名とカラム名をビューにドラッグアンドドロップすることも可能です。

データのビジュアライゼーションを作成

[Design]タブで、テーブルをチャートやその他のビジュアライゼーションに変更できます。