Tibco Spotfire から、ODBC 経由でDocuSign データに連携してビジュアライズ

詳細情報をご希望ですか?

無償トライアル:

ダウンロードへ

製品の詳細情報へ:

DocuSign ODBC Driver

DocuSign ODBC Driver を使って、ODBC 接続をサポートするあらゆるアプリケーション・ツールからDocuSign データに連携。

DocuSign にデータベースのようにアクセス - Accounts、Envelopes、Folders にODBC インターフェースで接続。



ODBC 標準はユビキタスをサポートし、セルフサービスBI を簡単にします。ODBC Driver を使ってDocuSign をTIBCO Spotfire にローディングします。



この記事では、CData ODBC Driver for DocuSign をTIBCO Spotfire で使う方法を説明します。データインポートウィザードを使ってのDSN(データソース名)に接続し、サンプルビジュアライゼーション上でビルドして簡単なダッシュボードを作成します。

  1. 接続プロパティの指定がまだの場合は、DSN (データソース名)で行います。Microsoft ODBC データソースアドミニストレーターを使ってODBC DSN を作成および設定できます。一般的な接続プロパティは以下のとおりです:

    • OAuthClientId
    • OAuthClientSecret
    • CallbackURL

    Microsoft ODBC データソースアドミニストレーターで必要なプロパティを設定する方法は、ヘルプドキュメントの「はじめに」をご参照ください。

    DocuSign への接続には以下の接続プロパティを設定します:

    • UseSandbox: UseSandbox は現在のユーザーアカウントがサンドボックスかそうでないかを示します。デフォルトはfalse です。サンドボックスアカウントがある場合はTrue に設定します。
    • AccountId (optional): 認証が成功すると自動的に設定されます。 または、複数のAccount Id にアクセスできる場合は、接続文字列で手動で設定できます。アカウントId を取得するには、UserInfo ビューをクエリします。

    DocuSign への認証

    DocuSign はOAuth 認証標準を利用しています。OAuth を使って認証するには、アプリケーションを作成してOAuthClientId、OAuthClientSecret、およびCallbackURL 接続プロパティを取得しなければなりません。認証方法については、ヘルプドキュメントの「OAuth 認証の使用」を参照してください。

  2. [File]>[Add Data Tables]をクリックします。
  3. ライブデータを使いたい場合は、[Keep Data Table External]オプションをクリックします。このオプションは、データの変更をリアルタイムでダッシュボードに反映します。また、大量のデータを扱う場合に、ネットワークのロード回数を低減します。

    データをメモリにロードしてローカルで処理したい場合は、[Import Data Table]オプションをクリックします。このオプションは、オフラインでの使用、またはスローなネットワーク接続によりダッシュボードがインタラクティブでない場合に使用します。

  4. [Add]>[Database]をクリックします。
  5. [Data Source Type]メニューでODBC Provider を選択し[Configure]をクリックします。
  6. DSN を選択します。
  7. ダッシュボードに追加したいテーブルを選択します。この例ではDocuments を使います。SQL クエリも指定できます。ドライバーは標準SQL シンタックスをサポートしています。
  8. テーブルを追加すると[Recommended Visualizations]ウィザードが表示されます。テーブルを選択すると、Spotfire はカラムのデータ型を使ってnumber、time、category カラムを検出します。この例ではNumbers セクションでDocumentName を、Categories セクションでDocumentId を使用しています。

[Recommended Visualizations]ウィザードでいくつかビジュアライズしたら、ダッシュボードにその他の修正を加えられます。例えば、ページにフィルタを適用することで、高確率なopportunities にズームインできます。フィルタを追加するには、[Filter]ボタンをクリックします。各クエリで利用可能なフィルタは、[Filters]ペインに表示されます。