Visio Shapes とDocuSign Data を連携

詳細情報をご希望ですか?

無償トライアル:

ダウンロードへ

製品の詳細情報へ:

DocuSign ODBC Driver

DocuSign ODBC Driver を使って、ODBC 接続をサポートするあらゆるアプリケーション・ツールからDocuSign データに連携。

DocuSign にデータベースのようにアクセス - Accounts、Envelopes、Folders にODBC インターフェースで接続。



Visio master shapes での変更を自動的にDocuSign data に更新。

Automate the process of entering data into Visio diagrams and keeping your diagrams up to date with the CData ODBC Driver for DocuSign. The driver surfaces DocuSign data as an ODBC data source that can be accessed by applications with built-in ODBC support like Microsoft Office. This article shows how to create a simple diagram to start brainstorming about Visio projects linked to DocuSign data.

Connect to DocuSign as an ODBC Data Source

If you have not already, first specify connection properties in an ODBC DSN (data source name). This is the last step of the driver installation. You can use the Microsoft ODBC Data Source Administrator to create and configure ODBC DSNs.

DocuSign への接続には以下の接続プロパティを設定します:

  • UseSandbox: UseSandbox は現在のユーザーアカウントがサンドボックスかそうでないかを示します。デフォルトはfalse です。サンドボックスアカウントがある場合はTrue に設定します。
  • AccountId (optional): 認証が成功すると自動的に設定されます。 または、複数のAccount Id にアクセスできる場合は、接続文字列で手動で設定できます。アカウントId を取得するには、UserInfo ビューをクエリします。

DocuSign への認証

DocuSign はOAuth 認証標準を利用しています。OAuth を使って認証するには、アプリケーションを作成してOAuthClientId、OAuthClientSecret、およびCallbackURL 接続プロパティを取得しなければなりません。認証方法については、ヘルプドキュメントの「OAuth 認証の使用」を参照してください。

Connect DocuSign Data to Diagrams

Follow the steps below to use the Data Selector Wizard to import data into your diagram.

  1. Open Visio and click File -> New. Open the Brainstorming template.
  2. On the Data tab, click Link Data to Shapes.
  3. Select the ODBC option and select ODBC DSN.
  4. Select the DSN for DocuSign, select the table you want to import, and finish the wizard. This article uses Documents as an example.

Link DocuSign Entities to Shapes

Follow the steps below to create a simple diagram that shows how to create shapes from your data, one of the ways to link DocuSign entities to shapes:

  1. Click Brainstorming Shapes and drag a main topic onto the drawing page. Enter Documents as the text of the main topic.
  2. Click Topic.
  3. Select a row in the External Data window and drag it onto the drawing page.
  4. Right-click the Topic shape and click Data -> Edit Data Graphic.
  5. Click New Item.
  6. In the Data Field menu, select a column. In the Displayed As menu, select how to display them.
  7. Drag a few other DocuSign entities onto the drawing page and add association lines back to the main topic, Documents. New topics have the same configuration: Numeric columns displayed in data bars stand out in contrast to other Documents entities.

You can refresh your diagram from the Data tab, synchronizing your shapes with the external DocuSign data.