Visio Shapes とDynamics GP Data を連携

詳細情報をご希望ですか?

無償トライアル:

ダウンロードへ

製品の詳細情報へ:

Dynamics GP ODBC Driver

Dynamics GP ODBC ドライバーは、ODBC 接続をサポートする任意のアプリケーションからリアルタイムなDynamics GP データに直接接続できるパワフルなツールです。標準のODBC ドライバーインタフェースを使用して、データベースのようにDynamics GP にアクセスし、ベンダー、顧客、請求書、見積もりなどの読み、書き、更新を実行できます。



Visio master shapes での変更を自動的にDynamics GP data に更新。

Automate the process of entering data into Visio diagrams and keeping your diagrams up to date with the CData ODBC Driver for Dynamics GP. The driver surfaces Dynamics GP data as an ODBC data source that can be accessed by applications with built-in ODBC support like Microsoft Office. This article shows how to create a simple diagram to start brainstorming about Visio projects linked to Dynamics GP data.

Connect to Dynamics GP as an ODBC Data Source

If you have not already, first specify connection properties in an ODBC DSN (data source name). This is the last step of the driver installation. You can use the Microsoft ODBC Data Source Administrator to create and configure ODBC DSNs.

認証するには、User およびPassword 接続プロパティを設定します。

接続するには、Url をWeb サービスのエンドポイントに設定します。例えば、http://{servername}:{port}/Dynamics/GPService です。さらに、CompanyId を設定します。この値は組織のセットアップウィンドウで[ツール]->[設定]->[組織]をクリックして取得できます。

デフォルトでデータサマリを返し、パフォーマンスを節約します。Line items などの詳細を返すには、LookupIds をtrue に設定します。ただしエンティティは一度に一つずつ返される必要があります。

Connect Dynamics GP Data to Diagrams

Follow the steps below to use the Data Selector Wizard to import data into your diagram.

  1. Open Visio and click File -> New. Open the Brainstorming template.
  2. On the Data tab, click Link Data to Shapes.
  3. Select the ODBC option and select ODBC DSN.
  4. Select the DSN for Dynamics GP, select the table you want to import, and finish the wizard. This article uses SalesInvoice as an example.

Link Dynamics GP Entities to Shapes

Follow the steps below to create a simple diagram that shows how to create shapes from your data, one of the ways to link Dynamics GP entities to shapes:

  1. Click Brainstorming Shapes and drag a main topic onto the drawing page. Enter SalesInvoice as the text of the main topic.
  2. Click Topic.
  3. Select a row in the External Data window and drag it onto the drawing page.
  4. Right-click the Topic shape and click Data -> Edit Data Graphic.
  5. Click New Item.
  6. In the Data Field menu, select a column. In the Displayed As menu, select how to display them.
  7. Drag a few other Dynamics GP entities onto the drawing page and add association lines back to the main topic, SalesInvoice. New topics have the same configuration: Numeric columns displayed in data bars stand out in contrast to other SalesInvoice entities.

You can refresh your diagram from the Data tab, synchronizing your shapes with the external Dynamics GP data.