製品情報をご覧ください

製品情報や無償評価版を製品ページにてご確認いただけます。

製品ページへ

Visio Shapes とFedEx Data を連携

Visio master shapes での変更を自動的にFedEx data に更新。

Automate the process of entering data into Visio diagrams and keeping your diagrams up to date with the CData ODBC Driver for FedEx. The driver surfaces FedEx data as an ODBC data source that can be accessed by applications with built-in ODBC support like Microsoft Office. This article shows how to create a simple diagram to start brainstorming about Visio projects linked to FedEx data.

Connect to FedEx as an ODBC Data Source

If you have not already, first specify connection properties in an ODBC DSN (data source name). This is the last step of the driver installation. You can use the Microsoft ODBC Data Source Administrator to create and configure ODBC DSNs.

FedEx サービスでのアクションを認証するためには以下の5つの情報が必要です。

  • Server:リクエストを送信するURL を制御します。一般的なテストオプションは次のとおりです:"https://gatewaybeta.fedex.com:443/xml"、"https://wsbeta.fedex.com:443/xml"、"https://gatewaybeta.fedex.com:443/web-service"、および"https://wsbeta.fedex.com:443/web-service"
  • DeveloperKey:荷送人のID の認証キーの識別子部分。この値は、登録後にFedEx から提供されます。
  • Password:荷送人のID の認証キーのシークレット部分。この値は、登録後にFedEx から提供されます。
  • AccountNumber:この有効な9桁のFedEx アカウント番号は、FedEx サーバーへのログインに使用されます。
  • MeterNumber:この値はFedEx にリクエストを送信するために使用されます。この値は、登録後にFedEx から提供されます。
  • PrintLabelLocation:このプロパティはGenerateLabels またはGenerateReturnLabels ストアドプロシージャを使用するために必要です。これは、生成されたラベルを格納するフォルダの場所に設定する必要があります。

キャッシュデータベース

FedEx から利用できる便利なタスクの多くは、大量のデータを必要とします。データを簡単に入力して後で呼び出すことができるように、キャッシュデータベースを活用してこれらのリクエストを行います。キャッシュ接続プロパティを設定する必要があります。

  • CacheLocation:デフォルトのキャッシュプロバイダーを使用して接続を構成するキャッシュの場所へのパス。例えば、C:\users\username\documents\fedexcache

CacheLocation の代わりとして、CacheConnection とCacheProvider の組み合わせを設定して、デフォルトとは別のプロバイダーを使用してキャッシュ接続を構成します。

Connect FedEx Data to Diagrams

Follow the steps below to use the Data Selector Wizard to import data into your diagram.

  1. Open Visio and click File -> New. Open the Brainstorming template.
  2. On the Data tab, click Link Data to Shapes.
  3. Select the ODBC option and select ODBC DSN.
  4. Select the DSN for FedEx, select the table you want to import, and finish the wizard. This article uses Senders as an example.

Link FedEx Entities to Shapes

Follow the steps below to create a simple diagram that shows how to create shapes from your data, one of the ways to link FedEx entities to shapes:

  1. Click Brainstorming Shapes and drag a main topic onto the drawing page. Enter Senders as the text of the main topic.
  2. Click Topic.
  3. Select a row in the External Data window and drag it onto the drawing page.
  4. Right-click the Topic shape and click Data -> Edit Data Graphic.
  5. Click New Item.
  6. In the Data Field menu, select a column. In the Displayed As menu, select how to display them.
  7. Drag a few other FedEx entities onto the drawing page and add association lines back to the main topic, Senders. New topics have the same configuration: Numeric columns displayed in data bars stand out in contrast to other Senders entities.

You can refresh your diagram from the Data tab, synchronizing your shapes with the external FedEx data.

 
 
ダウンロード