今すぐお試しください!

製品の詳細CData ODBC Driver for Google Analytics を確認して、無償評価版をダウンロード:

今すぐダウンロード

Visio Shapes とGoogle Analytics Data を連携

Visio master shapes での変更を自動的にGoogle Analytics data に更新。

Automate the process of entering data into Visio diagrams and keeping your diagrams up to date with the CData ODBC Driver for Google Analytics. The driver surfaces Google Analytics data as an ODBC data source that can be accessed by applications with built-in ODBC support like Microsoft Office. This article shows how to create a simple diagram to start brainstorming about Visio projects linked to Google Analytics data.

Connect to Google Analytics as an ODBC Data Source

If you have not already, first specify connection properties in an ODBC DSN (data source name). This is the last step of the driver installation. You can use the Microsoft ODBC Data Source Administrator to create and configure ODBC DSNs.

OAuth 認証標準を使用してGoogle Analytics に接続します。ユーザーアカウントまたはサービスアカウントで認証できます。組織全体のアクセススコープを本製品に許可するには、サービスアカウントが必要です。下記で説明するとおり、本製品はこれらの認証フローをサポートします。

ユーザー資格情報の接続プロパティを設定せずに接続できます。次を設定して、接続してください。 Profile:接続するGoogle アナリティクスのプロファイル、またはビューに設定。この値はProfiles テーブルから取得できます。指定しない場合は、初めに返されたプロファイルが使われます。接続すると、本製品はデフォルトブラウザでOAuth エンドポイントを開きます。ログインして、アプリケーションにアクセス許可を与えます。本製品がOAuth プロセスを完了します。他のOAuth 認証フローについては、ヘルプドキュメントの「OAuth 認証の使用」を参照してください。

Connect Google Analytics Data to Diagrams

Follow the steps below to use the Data Selector Wizard to import data into your diagram.

  1. Open Visio and click File -> New. Open the Brainstorming template.
  2. On the Data tab, click Link Data to Shapes.
  3. Select the ODBC option and select ODBC DSN.
  4. Select the DSN for Google Analytics, select the table you want to import, and finish the wizard. This article uses Traffic as an example.

Link Google Analytics Entities to Shapes

Follow the steps below to create a simple diagram that shows how to create shapes from your data, one of the ways to link Google Analytics entities to shapes:

  1. Click Brainstorming Shapes and drag a main topic onto the drawing page. Enter Traffic as the text of the main topic.
  2. Click Topic.
  3. Select a row in the External Data window and drag it onto the drawing page.
  4. Right-click the Topic shape and click Data -> Edit Data Graphic.
  5. Click New Item.
  6. In the Data Field menu, select a column. In the Displayed As menu, select how to display them.
  7. Drag a few other Google Analytics entities onto the drawing page and add association lines back to the main topic, Traffic. New topics have the same configuration: Numeric columns displayed in data bars stand out in contrast to other Traffic entities.

You can refresh your diagram from the Data tab, synchronizing your shapes with the external Google Analytics data.

 
 
ダウンロード