Tibco Spotfire から、ODBC 経由でGmail データに連携してビジュアライズ

製品をチェック

無償トライアル:

ダウンロードへ

製品の詳細情報へ:

Gmail ODBC Driver

Gmail ODBC ドライバーは、ODBC 接続をサポートする任意のアプリケーションからリアルタイムなインターネット電子メール(Gmail)に直接接続できるパワフルなツールです。標準のODBC ドライバーインターフェースを使用して、データベースのようにGmail フォルダおよびメッセージデータにアクセスし、電子メールの読み出し、書き込み、および送信を実行できます。

データ連携でお困りですか?

お問い合わせ

ODBC 標準はユビキタスをサポートし、セルフサービスBI を簡単にします。ODBC Driver を使ってGmail をTIBCO Spotfire にローディングします。





この記事では、CData ODBC Driver for Gmail をTIBCO Spotfire で使う方法を説明します。データインポートウィザードを使ってのDSN(データソース名)に接続し、サンプルビジュアライゼーション上でビルドして簡単なダッシュボードを作成します。

  1. 接続プロパティの指定がまだの場合は、DSN (データソース名)で行います。Microsoft ODBC データソースアドミニストレーターを使ってODBC DSN を作成および設定できます。一般的な接続プロパティは以下のとおりです:

    • User
    • Password

    Microsoft ODBC データソースアドミニストレーターで必要なプロパティを設定する方法は、ヘルプドキュメントの「はじめに」をご参照ください。

    Gmail に接続する方法は2つあります。ログインクレデンシャルかOAuth のいずれかを選択する前に、まずGmail のアカウント設定でIMAP アクセスを有効にしてください。詳しくは、ヘルプドキュメントの「はじめに」-「Gmail への接続」を参照してください。

    Authentication セクションのUser とPassword プロパティに、有効なGmail ユーザー資格情報を設定します。

    あるいは、Password を指定する代わりに、OAuth 認証標準を使います。 個々のユーザーに代わってGoogle API にアクセスするには、埋め込みクレデンシャルを使用するか、独自のOAuth アプリを登録することができます。

    また、OAuth を利用することで、Google Apps ドメイン内のユーザーに代わってサービスアカウントを使用して接続することができます。サービスアカウントで認証するには、アプリケーションを登録してOAuth JWT 値を取得する必要があります。

    OAuth 値に加え、User を指定する必要があります。詳しくは、ヘルプドキュメントの「はじめに」を参照してください。

  2. [File]>[Add Data Tables]をクリックします。
  3. ライブデータを使いたい場合は、[Keep Data Table External]オプションをクリックします。このオプションは、データの変更をリアルタイムでダッシュボードに反映します。また、大量のデータを扱う場合に、ネットワークのロード回数を低減します。

    データをメモリにロードしてローカルで処理したい場合は、[Import Data Table]オプションをクリックします。このオプションは、オフラインでの使用、またはスローなネットワーク接続によりダッシュボードがインタラクティブでない場合に使用します。

  4. [Add]>[Database]をクリックします。
  5. [Data Source Type]メニューでODBC Provider を選択し[Configure]をクリックします。
  6. DSN を選択します。
  7. ダッシュボードに追加したいテーブルを選択します。この例ではInbox を使います。SQL クエリも指定できます。ドライバーは標準SQL シンタックスをサポートしています。
  8. テーブルを追加すると[Recommended Visualizations]ウィザードが表示されます。テーブルを選択すると、Spotfire はカラムのデータ型を使ってnumber、time、category カラムを検出します。この例ではNumbers セクションでSize を、Categories セクションでSubject を使用しています。

[Recommended Visualizations]ウィザードでいくつかビジュアライズしたら、ダッシュボードにその他の修正を加えられます。例えば、ページにフィルタを適用することで、高確率なopportunities にズームインできます。フィルタを追加するには、[Filter]ボタンをクリックします。各クエリで利用可能なフィルタは、[Filters]ペインに表示されます。