Visio Shapes とGmail Data を連携

詳細情報をご希望ですか?

無償トライアル:

ダウンロードへ

製品の詳細情報へ:

Gmail ODBC Driver

Gmail ODBC ドライバーは、ODBC 接続をサポートする任意のアプリケーションからリアルタイムなインターネット電子メール(Gmail)に直接接続できるパワフルなツールです。標準のODBC ドライバーインタフェースを使用して、データベースのようにGmail フォルダーおよびメッセージデータにアクセスし、電子メールの読み出し、書き込み、および送信を実行できます。



Visio master shapes での変更を自動的にGmail data に更新。

Automate the process of entering data into Visio diagrams and keeping your diagrams up to date with the CData ODBC Driver for Gmail. The driver surfaces Gmail data as an ODBC data source that can be accessed by applications with built-in ODBC support like Microsoft Office. This article shows how to create a simple diagram to start brainstorming about Visio projects linked to Gmail data.

Connect to Gmail as an ODBC Data Source

If you have not already, first specify connection properties in an ODBC DSN (data source name). This is the last step of the driver installation. You can use the Microsoft ODBC Data Source Administrator to create and configure ODBC DSNs.

Gmail に接続する方法は2つあります。ログインクレデンシャルかOAuth のいずれかを選択する前に、まずGmail のアカウント設定でIMAP アクセスを有効にしてください。詳しくは、ヘルプドキュメントの「はじめに」-「Gmail への接続」を参照してください。

Authentication セクションのUser とPassword プロパティに、有効なGmail ユーザー資格情報を設定します。

あるいは、Password を指定する代わりに、OAuth 認証標準を使います。 個々のユーザーに代わってGoogle API にアクセスするには、埋め込みクレデンシャルを使用するか、独自のOAuth アプリを登録することができます。

また、OAuth を利用することで、Google Apps ドメイン内のユーザーに代わってサービスアカウントを使用して接続することができます。サービスアカウントで認証するには、アプリケーションを登録してOAuth JWT 値を取得する必要があります。

OAuth 値に加え、User を指定する必要があります。詳しくは、ヘルプドキュメントの「はじめに」を参照してください。

Connect Gmail Data to Diagrams

Follow the steps below to use the Data Selector Wizard to import data into your diagram.

  1. Open Visio and click File -> New. Open the Brainstorming template.
  2. On the Data tab, click Link Data to Shapes.
  3. Select the ODBC option and select ODBC DSN.
  4. Select the DSN for Gmail, select the table you want to import, and finish the wizard. This article uses Inbox as an example.

Link Gmail Entities to Shapes

Follow the steps below to create a simple diagram that shows how to create shapes from your data, one of the ways to link Gmail entities to shapes:

  1. Click Brainstorming Shapes and drag a main topic onto the drawing page. Enter Inbox as the text of the main topic.
  2. Click Topic.
  3. Select a row in the External Data window and drag it onto the drawing page.
  4. Right-click the Topic shape and click Data -> Edit Data Graphic.
  5. Click New Item.
  6. In the Data Field menu, select a column. In the Displayed As menu, select how to display them.
  7. Drag a few other Gmail entities onto the drawing page and add association lines back to the main topic, Inbox. New topics have the same configuration: Numeric columns displayed in data bars stand out in contrast to other Inbox entities.

You can refresh your diagram from the Data tab, synchronizing your shapes with the external Gmail data.