今すぐお試しください!

製品の詳細CData ODBC Driver for Google Drive を確認して、無償評価版をダウンロード:

今すぐダウンロード

Visio Shapes とGoogle Drive Data を連携

Visio master shapes での変更を自動的にGoogle Drive data に更新。

Automate the process of entering data into Visio diagrams and keeping your diagrams up to date with the CData ODBC Driver for Google Drive. The driver surfaces Google Drive data as an ODBC data source that can be accessed by applications with built-in ODBC support like Microsoft Office. This article shows how to create a simple diagram to start brainstorming about Visio projects linked to Google Drive data.

Connect to Google Drive as an ODBC Data Source

If you have not already, first specify connection properties in an ODBC DSN (data source name). This is the last step of the driver installation. You can use the Microsoft ODBC Data Source Administrator to create and configure ODBC DSNs.

Google Drive はOAuth 認証標準を利用しています。各ユーザーやドメイン内のユーザーの代わりに、本製品がGoogle API にアクセスすることを許可できます。 接続すると、本製品はデフォルトブラウザでOAuth エンドポイントを開きます。ログインして、アプリケーションにアクセス許可を与えます。本製品がOAuth プロセスを完了します。

詳細はヘルプドキュメントを参照してください。

Connect Google Drive Data to Diagrams

Follow the steps below to use the Data Selector Wizard to import data into your diagram.

  1. Open Visio and click File -> New. Open the Brainstorming template.
  2. On the Data tab, click Link Data to Shapes.
  3. Select the ODBC option and select ODBC DSN.
  4. Select the DSN for Google Drive, select the table you want to import, and finish the wizard. This article uses Files as an example.

Link Google Drive Entities to Shapes

Follow the steps below to create a simple diagram that shows how to create shapes from your data, one of the ways to link Google Drive entities to shapes:

  1. Click Brainstorming Shapes and drag a main topic onto the drawing page. Enter Files as the text of the main topic.
  2. Click Topic.
  3. Select a row in the External Data window and drag it onto the drawing page.
  4. Right-click the Topic shape and click Data -> Edit Data Graphic.
  5. Click New Item.
  6. In the Data Field menu, select a column. In the Displayed As menu, select how to display them.
  7. Drag a few other Google Drive entities onto the drawing page and add association lines back to the main topic, Files. New topics have the same configuration: Numeric columns displayed in data bars stand out in contrast to other Files entities.

You can refresh your diagram from the Data tab, synchronizing your shapes with the external Google Drive data.

 
 
ダウンロード