Power View でのHPCC Systems データのインポートとビジュアライズ

詳細情報をご希望ですか?

無償トライアル:

ダウンロードへ

製品の詳細情報へ:

HPCC ODBC Driver

HPCC ODBC ドライバーは、ODBC 接続をサポートする任意のアプリケーションからリアルタイムなHPCC ECL クエリーデータに直接接続できるパワフルなツールです。標準のODBC ドライバーインタフェースを使用して、データベースのようにLexisNexis などのHPCC システムにアクセスし、データの読み、書き、更新を実行できます。



Excel でHPCC Systems データを使ったデータビジュアライゼーションを作成します。

Excel に組み込まれているODBC サポートを使用して、HPCC Systems データを使用したPower View レポートを素早く作成できます。この記事では、Data リボンからアクセスできるData Connection Wizard を使用して、HPCC Systems をPower View レポートにインポートする方法を説明します。

ODBC Data Source としてHPCC Systems に接続

未指定の場合は、初めにODBC DSN (data source name) で接続プロパティを指定します。ドライバーのインストールの最後にアドミニストレーターが開きます。Microsoft ODBC Data Source Administrator を使用して、ODBC DSN を作成および構成できます。

接続するには、次の接続プロパティを設定します。Url をサーバーのマシン名もしくはIP アドレス、およびサーバーが起動しているポートに設定します。例えば、https://server:port。Url で指定されたHPCC システムへの認証には、User およびPassword が必要です。LDAP 認証は、現在サポートされていません。

Version をWsSQL Web サーバーのバージョンに設定します。HPCC サーバーにWsSQL サービスをインストールしておく必要があることに注意してください。本製品は、HPCC システムへの連携にWsSQL Web サービスを使います。

Cluster をターゲットクラスタに設定します。

DSN を構成する際に、Max Rows プロパティを定めることも可能です。これによって返される行数が制限されるので、ビジュアライゼーション・レポートのデザイン時のパフォーマンスを向上させるのに役立ちます。

Data Connection Wizard で接続

以下のステップに従って、Excel のData Connection Wizard からDSN に接続します。

  1. [Data]タブで、[From Other Sources]->[From Data Connection Wizard]とクリックします。
  2. [Data Connection Wizard]で[ODBC DSN]オプションを選択します。
  3. リストから[ODBC DSN for HPCC Systems]を選択します。
  4. 操作するテーブルを選択します。

    複数のテーブルをインポートする場合は、[Connect to a specific table]オプションの選択を解除します。データソースに接続したら、複数のテーブルを選択できます。[Finish]をクリックして[Data Connection Wizard]を閉じた後、[Select Table]ダイアログで[Enable selection of multiple tables]オプションを選択します。

  5. [Import Data]ダイアログで、データのインポート先を選択します。例えば、[Table]オプションと[Existing worksheet]オプションを選択します。次に、結果を出力するワークシートのセルをクリックします。
  6. [Insert]->[Power View]とクリックして新しいPower View レポートを作成します。

テーブルの作成

テーブルは、チャートやその他のデータの表現の開始点です。テーブルを作成するには、フィールドリストでカラムを選択します。テーブル名とカラム名をビューにドラッグアンドドロップすることも可能です。

データのビジュアライゼーションを作成

[Design]タブで、テーブルをチャートやその他のビジュアライゼーションに変更できます。