Visio Shapes とKafka Data を連携

詳細情報をご希望ですか?

無償トライアル:

ダウンロードへ

製品の詳細情報へ:

Apache Kafka ODBC Driver

Apache Kafka ODBC Driver を使って、ODBC 接続をサポートするあらゆるアプリケーション・ツールからApache Kafka にデータ連携。

Apache Kafka データストリームにデータベースと同感覚でアクセスして、トピックに使い慣れたODBC インターフェースで双方向連携。



Visio master shapes での変更を自動的にKafka data に更新。

Automate the process of entering data into Visio diagrams and keeping your diagrams up to date with the CData ODBC Driver for Kafka. The driver surfaces Kafka data as an ODBC data source that can be accessed by applications with built-in ODBC support like Microsoft Office. This article shows how to create a simple diagram to start brainstorming about Visio projects linked to Kafka data.

Connect to Kafka as an ODBC Data Source

If you have not already, first specify connection properties in an ODBC DSN (data source name). This is the last step of the driver installation. You can use the Microsoft ODBC Data Source Administrator to create and configure ODBC DSNs.

BootstrapServers およびTopic プロパティを設定して、Apache Kafka サーバーのアドレスと、対話するトピックを指定します。

認可メカニズム

  • SASL PlainUser およびPassword プロパティを指定する必要があります。AuthScheme は'Plain' に設定します。
  • SASL SSLUser およびPassword プロパティを指定する必要があります。AuthScheme は'Scram' に、UseSSL はtrue に設定します。
  • SSLSSLCert およびSSLCertPassword プロパティを指定する必要があります。UseSSL はtrue に設定します。
  • KerberosUser およびPassword プロパティを指定する必要があります。AuthScheme は'Kerberos' に設定します。

サーバー証明書を信頼する必要がある場合があります。そのような場合は、必要に応じてTrustStorePath およびTrustStorePassword を指定してください。

Connect Kafka Data to Diagrams

Follow the steps below to use the Data Selector Wizard to import data into your diagram.

  1. Open Visio and click File -> New. Open the Brainstorming template.
  2. On the Data tab, click Link Data to Shapes.
  3. Select the ODBC option and select ODBC DSN.
  4. Select the DSN for Kafka, select the table you want to import, and finish the wizard. This article uses SampleTable_1 as an example.

Link Kafka Entities to Shapes

Follow the steps below to create a simple diagram that shows how to create shapes from your data, one of the ways to link Kafka entities to shapes:

  1. Click Brainstorming Shapes and drag a main topic onto the drawing page. Enter SampleTable_1 as the text of the main topic.
  2. Click Topic.
  3. Select a row in the External Data window and drag it onto the drawing page.
  4. Right-click the Topic shape and click Data -> Edit Data Graphic.
  5. Click New Item.
  6. In the Data Field menu, select a column. In the Displayed As menu, select how to display them.
  7. Drag a few other Kafka entities onto the drawing page and add association lines back to the main topic, SampleTable_1. New topics have the same configuration: Numeric columns displayed in data bars stand out in contrast to other SampleTable_1 entities.

You can refresh your diagram from the Data tab, synchronizing your shapes with the external Kafka data.