今すぐお試しください!

製品の詳細CData ODBC Driver for Lohaco を確認して、無償評価版をダウンロード:

今すぐダウンロード

Visio Shapes とLohaco Data を連携

Visio master shapes での変更を自動的にLohaco data に更新。

Automate the process of entering data into Visio diagrams and keeping your diagrams up to date with the CData ODBC Driver for Lohaco. The driver surfaces Lohaco data as an ODBC data source that can be accessed by applications with built-in ODBC support like Microsoft Office. This article shows how to create a simple diagram to start brainstorming about Visio projects linked to Lohaco data.

Connect to Lohaco as an ODBC Data Source

If you have not already, first specify connection properties in an ODBC DSN (data source name). This is the last step of the driver installation. You can use the Microsoft ODBC Data Source Administrator to create and configure ODBC DSNs.

Lohaco に接続する場合は、 SellerId、SSLClientCert、およびSSLClientCertType が必要です。

Lohaco へのアクセスの設定

SellerId、SSLClientCert、およびSSLClientCertType を取得するには、以下の手順に従ってください。

  • 「API 認証について」を参照して公開鍵と秘密鍵を生成します。
  • Lohaco ストアクリエイターにログインして、[設定]メニューの[証明書設定]に移動します。
  • [証明書を登録]をクリックして[公開鍵]、[許可IPアドレス]、[有効期限]を入力します。

Lohaco アカウントの認証

次の接続プロパティを設定して接続します。

  • SellerId:接続先のLohaco Store ID を設定。
  • SSLClientCert:プライベートキーのファイルパスを設定。
  • SSLClientCertType:値"PEMKEY_FILE" を設定。

Connect Lohaco Data to Diagrams

Follow the steps below to use the Data Selector Wizard to import data into your diagram.

  1. Open Visio and click File -> New. Open the Brainstorming template.
  2. On the Data tab, click Link Data to Shapes.
  3. Select the ODBC option and select ODBC DSN.
  4. Select the DSN for Lohaco, select the table you want to import, and finish the wizard. This article uses Items as an example.

Link Lohaco Entities to Shapes

Follow the steps below to create a simple diagram that shows how to create shapes from your data, one of the ways to link Lohaco entities to shapes:

  1. Click Brainstorming Shapes and drag a main topic onto the drawing page. Enter Items as the text of the main topic.
  2. Click Topic.
  3. Select a row in the External Data window and drag it onto the drawing page.
  4. Right-click the Topic shape and click Data -> Edit Data Graphic.
  5. Click New Item.
  6. In the Data Field menu, select a column. In the Displayed As menu, select how to display them.
  7. Drag a few other Lohaco entities onto the drawing page and add association lines back to the main topic, Items. New topics have the same configuration: Numeric columns displayed in data bars stand out in contrast to other Items entities.

You can refresh your diagram from the Data tab, synchronizing your shapes with the external Lohaco data.

 
 
ダウンロード