Tibco Spotfire から、ODBC 経由でSalesforce Pardot データに連携してビジュアライズ

詳細情報をご希望ですか?

無償トライアル:

ダウンロードへ

製品の詳細情報へ:

Salesforce Pardot ODBC Driver

Salesforce Pardot ODBC Driver を使って、ODBC 接続をサポートするあらゆるアプリケーション・ツールからSalesforce Pardot にデータ連携。

Salesforce Pardot データにデータベースと同感覚でアクセスして、Salesforce Pardot のEmails、Lists、Opportunities、Users データに使い慣れたODBC インターフェースで双方向連携。



ODBC 標準はユビキタスをサポートし、セルフサービスBI を簡単にします。ODBC Driver を使ってSalesforce Pardot をTIBCO Spotfire にローディングします。



この記事では、CData ODBC Driver for Salesforce Pardot をTIBCO Spotfire で使う方法を説明します。データインポートウィザードを使ってのDSN(データソース名)に接続し、サンプルビジュアライゼーション上でビルドして簡単なダッシュボードを作成します。

  1. 接続プロパティの指定がまだの場合は、DSN (データソース名)で行います。Microsoft ODBC データソースアドミニストレーターを使ってODBC DSN を作成および設定できます。一般的な接続プロパティは以下のとおりです:

    • ApiVersion
    • User
    • Password
    • UserKey

    Microsoft ODBC データソースアドミニストレーターで必要なプロパティを設定する方法は、ヘルプドキュメントの「はじめに」をご参照ください。

    Salesforce Pardot はUsername、Password、およびUser Key を指定して接続します。

    • ApiVersion: 提供されたアカウントがアクセス可能なSalesforcePardot API バージョン。 デフォルトは4です。
    • User: Salesforce Pardot アカウントのユーザー名。
    • Password: Salesforce Pardot アカウントのパスワード。
    • UserKey: SalesforcePardot アカウントの一意のユーザーキー。このキーは永久的に利用できます。
    • IsDemoAccount (optional): でもアカウントの場合は、TRUE に設定。

    Pardot User Key へのアクセス

    現在のアカウントのUser Key にアクセスするには、「設定」->「My Profile」の「API User Key」行にアクセスします。

  2. [File]>[Add Data Tables]をクリックします。
  3. ライブデータを使いたい場合は、[Keep Data Table External]オプションをクリックします。このオプションは、データの変更をリアルタイムでダッシュボードに反映します。また、大量のデータを扱う場合に、ネットワークのロード回数を低減します。

    データをメモリにロードしてローカルで処理したい場合は、[Import Data Table]オプションをクリックします。このオプションは、オフラインでの使用、またはスローなネットワーク接続によりダッシュボードがインタラクティブでない場合に使用します。

  4. [Add]>[Database]をクリックします。
  5. [Data Source Type]メニューでODBC Provider を選択し[Configure]をクリックします。
  6. DSN を選択します。
  7. ダッシュボードに追加したいテーブルを選択します。この例ではProspects を使います。SQL クエリも指定できます。ドライバーは標準SQL シンタックスをサポートしています。
  8. テーブルを追加すると[Recommended Visualizations]ウィザードが表示されます。テーブルを選択すると、Spotfire はカラムのデータ型を使ってnumber、time、category カラムを検出します。この例ではNumbers セクションでEmail を、Categories セクションでId を使用しています。

[Recommended Visualizations]ウィザードでいくつかビジュアライズしたら、ダッシュボードにその他の修正を加えられます。例えば、ページにフィルタを適用することで、高確率なopportunities にズームインできます。フィルタを追加するには、[Filter]ボタンをクリックします。各クエリで利用可能なフィルタは、[Filters]ペインに表示されます。