Visio Shapes とSalesforce Pardot Data を連携

詳細情報をご希望ですか?

無償トライアル:

ダウンロードへ

製品の詳細情報へ:

Salesforce Pardot ODBC Driver

Salesforce Pardot ODBC Driver を使って、ODBC 接続をサポートするあらゆるアプリケーション・ツールからSalesforce Pardot にデータ連携。

Salesforce Pardot データにデータベースと同感覚でアクセスして、Salesforce Pardot のEmails、Lists、Opportunities、Users データに使い慣れたODBC インターフェースで双方向連携。



Visio master shapes での変更を自動的にSalesforce Pardot data に更新。

Automate the process of entering data into Visio diagrams and keeping your diagrams up to date with the CData ODBC Driver for Salesforce Pardot. The driver surfaces Salesforce Pardot data as an ODBC data source that can be accessed by applications with built-in ODBC support like Microsoft Office. This article shows how to create a simple diagram to start brainstorming about Visio projects linked to Salesforce Pardot data.

Connect to Salesforce Pardot as an ODBC Data Source

If you have not already, first specify connection properties in an ODBC DSN (data source name). This is the last step of the driver installation. You can use the Microsoft ODBC Data Source Administrator to create and configure ODBC DSNs.

Salesforce Pardot はUsername、Password、およびUser Key を指定して接続します。

  • ApiVersion: 提供されたアカウントがアクセス可能なSalesforcePardot API バージョン。 デフォルトは4です。
  • User: Salesforce Pardot アカウントのユーザー名。
  • Password: Salesforce Pardot アカウントのパスワード。
  • UserKey: SalesforcePardot アカウントの一意のユーザーキー。このキーは永久的に利用できます。
  • IsDemoAccount (optional): でもアカウントの場合は、TRUE に設定。

Pardot User Key へのアクセス

現在のアカウントのUser Key にアクセスするには、[設定]->[My Profile]の[API User Key]行にアクセスします。

Connect Salesforce Pardot Data to Diagrams

Follow the steps below to use the Data Selector Wizard to import data into your diagram.

  1. Open Visio and click File -> New. Open the Brainstorming template.
  2. On the Data tab, click Link Data to Shapes.
  3. Select the ODBC option and select ODBC DSN.
  4. Select the DSN for Salesforce Pardot, select the table you want to import, and finish the wizard. This article uses Prospects as an example.

Link Salesforce Pardot Entities to Shapes

Follow the steps below to create a simple diagram that shows how to create shapes from your data, one of the ways to link Salesforce Pardot entities to shapes:

  1. Click Brainstorming Shapes and drag a main topic onto the drawing page. Enter Prospects as the text of the main topic.
  2. Click Topic.
  3. Select a row in the External Data window and drag it onto the drawing page.
  4. Right-click the Topic shape and click Data -> Edit Data Graphic.
  5. Click New Item.
  6. In the Data Field menu, select a column. In the Displayed As menu, select how to display them.
  7. Drag a few other Salesforce Pardot entities onto the drawing page and add association lines back to the main topic, Prospects. New topics have the same configuration: Numeric columns displayed in data bars stand out in contrast to other Prospects entities.

You can refresh your diagram from the Data tab, synchronizing your shapes with the external Salesforce Pardot data.