Ready to get started?

Learn more about the CData ODBC Driver for PayPal or download a free trial:

Download Now

Visio Shapes とPayPal Data を連携

Visio master shapes での変更を自動的にPayPal data に更新。

Automate the process of entering data into Visio diagrams and keeping your diagrams up to date with the CData ODBC Driver for PayPal. The driver surfaces PayPal data as an ODBC data source that can be accessed by applications with built-in ODBC support like Microsoft Office. This article shows how to create a simple diagram to start brainstorming about Visio projects linked to PayPal data.

Connect to PayPal as an ODBC Data Source

If you have not already, first specify connection properties in an ODBC DSN (data source name). This is the last step of the driver installation. You can use the Microsoft ODBC Data Source Administrator to create and configure ODBC DSNs.

The provider surfaces tables from two PayPal APIs. The APIs use different authentication methods.

  • The REST API uses the OAuth standard. To authenticate to the REST API, you will need to set the OAuthClientId, OAuthClientSecret, and CallbackURL properties.
  • The Classic API requires Signature API credentials. To authenticate to the Classic API, you will need to obtain an API username, password, and signature.

See the "Getting Started" chapter of the help documentation for a guide to obtaining the necessary API credentials.

To select the API you want to work with, you can set the Schema property to REST or SOAP. By default the SOAP schema will be used.

For testing purposes you can set UseSandbox to true and use sandbox credentials.

Connect PayPal Data to Diagrams

Follow the steps below to use the Data Selector Wizard to import data into your diagram.

  1. Open Visio and click File -> New. Open the Brainstorming template.
  2. On the Data tab, click Link Data to Shapes.
  3. Select the ODBC option and select ODBC DSN.
  4. Select the DSN for PayPal, select the table you want to import, and finish the wizard. This article uses Transactions as an example.

Link PayPal Entities to Shapes

Follow the steps below to create a simple diagram that shows how to create shapes from your data, one of the ways to link PayPal entities to shapes:

  1. Click Brainstorming Shapes and drag a main topic onto the drawing page. Enter Transactions as the text of the main topic.
  2. Click Topic.
  3. Select a row in the External Data window and drag it onto the drawing page.
  4. Right-click the Topic shape and click Data -> Edit Data Graphic.
  5. Click New Item.
  6. In the Data Field menu, select a column. In the Displayed As menu, select how to display them.
  7. Drag a few other PayPal entities onto the drawing page and add association lines back to the main topic, Transactions. New topics have the same configuration: Numeric columns displayed in data bars stand out in contrast to other Transactions entities.

You can refresh your diagram from the Data tab, synchronizing your shapes with the external PayPal data.

 
 
ダウンロード