今すぐお試しください!

製品の詳細CData ODBC Driver for Redis を確認して、無償評価版をダウンロード:

今すぐダウンロード

Visio Shapes とRedis Data を連携

Visio master shapes での変更を自動的にRedis data に更新。

Automate the process of entering data into Visio diagrams and keeping your diagrams up to date with the CData ODBC Driver for Redis. The driver surfaces Redis data as an ODBC data source that can be accessed by applications with built-in ODBC support like Microsoft Office. This article shows how to create a simple diagram to start brainstorming about Visio projects linked to Redis data.

Connect to Redis as an ODBC Data Source

If you have not already, first specify connection properties in an ODBC DSN (data source name). This is the last step of the driver installation. You can use the Microsoft ODBC Data Source Administrator to create and configure ODBC DSNs.

次の接続プロパティを設定し、Redis インスタンスに接続します。

  • Server: Redis インスタンスが実行されているサーバーの名前またはアドレスに設定します。Port でポートを指定できます。
  • Password: Redis AUTH コマンドを使用するパスワード保護されたRedis インスタンスへの認証に使用されるパスワードに設定します。

UseSSL を設定すると、接続時にSSL/TLS 暗号化をネゴシエートできます。

Connect Redis Data to Diagrams

Follow the steps below to use the Data Selector Wizard to import data into your diagram.

  1. Open Visio and click File -> New. Open the Brainstorming template.
  2. On the Data tab, click Link Data to Shapes.
  3. Select the ODBC option and select ODBC DSN.
  4. Select the DSN for Redis, select the table you want to import, and finish the wizard. This article uses Customers as an example.

Link Redis Entities to Shapes

Follow the steps below to create a simple diagram that shows how to create shapes from your data, one of the ways to link Redis entities to shapes:

  1. Click Brainstorming Shapes and drag a main topic onto the drawing page. Enter Customers as the text of the main topic.
  2. Click Topic.
  3. Select a row in the External Data window and drag it onto the drawing page.
  4. Right-click the Topic shape and click Data -> Edit Data Graphic.
  5. Click New Item.
  6. In the Data Field menu, select a column. In the Displayed As menu, select how to display them.
  7. Drag a few other Redis entities onto the drawing page and add association lines back to the main topic, Customers. New topics have the same configuration: Numeric columns displayed in data bars stand out in contrast to other Customers entities.

You can refresh your diagram from the Data tab, synchronizing your shapes with the external Redis data.

 
 
ダウンロード