Ready to get started?

Learn more about the CData ODBC Driver for Sage 50 UK or download a free trial:

Download Now

Alteryx DesignerにてSage 50 UK Dataを、データプレパレーション・データブレンディング・分析

セルフサービスデータアナリティクスのためのSage 50 UK data へのライブ接続のWorkflowを構築

Sage 50 UK 用のCData ODBCドライバは、ODBC標準のSage 50 UKからのライブデータへのアクセスを可能にし、使い慣れたSQLクエリで多種多様なBI、レポート、ETLツールでSage 50 UK dataを扱うことができます 。 この記事では、セルフサービスBI、データプレパレーション、データブレンディング、アドバンスドアナリティクスを得意とするAlteryx DesignerでODBC接続を使用してSage 50 UK dataに接続して利用する方法を示します。

Sage 50 UK Dataへの接続

  1. まだ行っていない場合は、データソース名(DSN)に必要な接続プロパティの値を入力します。 組み込みのMicrosoft ODBCデータソースアドミニストレーターを使用してDSNを構成できます。 これは、ドライバのインストールじの最後のステップでも可能です。 Microsoft ODBCデータソースアドミニストレータを使用してDSNを作成および設定する方法については、ヘルプドキュメントの「はじめに」の章を参照してください。

    Note: Only Sage 50 UK 2012 and above are supported.

    The User and Password properties, under the Connection section, must be set to valid Sage 50 UK user credentials. These values will be the same used to log in to the Sage 50 UK software.

    Additionally, the URL property, under the Connection section, will need to be set to the address of the company dataset desired. To obtain the address, do the following:

    1. If you have not already done so, open the Sage 50 UK software.
    2. Click Tools -> Internet Options.
    3. Select the SData Settings tab.
    4. Click the Details button next to Sage 50 Accounts. A window is displayed containing a list of company names along with the address to their corresponding datasets.
    5. Set the URL property to the value in the address field next to the company desired.
  2. Alteryx Designer を開いて新しいワークフローを作成します。
  3. 新しいInput Data ToolをWorkflowにドラッグ&ドロップします。
  4. 新しい input data toolをクリックして、File or Database下の「Database Connection -> New ODBC Connection...」を選択します。
  5. Alteryx用に定義下設定済みDSNを選択します。
  6. 開かれたウィザードの中で、クエリーに含めたいフィールドを選択します。
  7. Sage 50 UK data内のデータを要件にあった内容で正確に取得しているかを確認する場合には、SQLEditorを開き、クエリーを手動で変更することができます。

クエリー定義で、Alteryx Designer内でSage 50 UK dataへの接続の準備ができました。

Sage 50 UK Dataに対するセルフサービス分析の実行

これで、Sage 50 UK dataのデータプレパレーション、ブレんディング、分析を行うワークフローを作成する準備が整いました。 以下の例では、データを整理して参照します。

  1. workflowにデータクレンジングツールを追加し、Nullテキストフィールドをブランクに置き換え、ヌル数値フィールドを0に置き換えるには、NULLを置き換えるのボックスをオンにします。また、不要な文字を削除するにチェックを入れて先頭と末尾の空白を削除することもできます。
  2. workflowにbrowse data toolを追加します。
  3. run the workflow (CTRL+R)をクリック。
  4. 結果ビューにてクレンジングされたSage 50 UK dataデータを確認します。
 
 
ダウンロード