Power View でのSage 50 UK データのインポートとビジュアライズ

詳細情報をご希望ですか?

無償トライアル:

ダウンロードへ

製品の詳細情報へ:

Sage UK ODBC Driver

Sage 50 UK ODBC ドライバーは、ODBC 接続をサポートする任意のアプリケーションからリアルタイムなSage 50 UK データに直接接続できるパワフルなツールです。標準のODBC ドライバーインタフェースを使用して、データベースのようにSage データにアクセスし、Sage の顧客、トランザクション、請求書、販売レシートなどの読み、書き、更新を実行できます。



Excel でSage 50 UK データを使ったデータビジュアライゼーションを作成します。

Excel に組み込まれているODBC サポートを使用して、Sage 50 UK データを使用したPower View レポートを素早く作成できます。この記事では、Data リボンからアクセスできるData Connection Wizard を使用して、Sage 50 UK をPower View レポートにインポートする方法を説明します。

ODBC Data Source としてSage 50 UK に接続

未指定の場合は、初めにODBC DSN (data source name) で接続プロパティを指定します。ドライバーのインストールの最後にアドミニストレーターが開きます。Microsoft ODBC Data Source Administrator を使用して、ODBC DSN を作成および構成できます。

Note:Sage 50 UK 2012 以降のみサポートされています。

[接続]セクションのUser およびPassword プロパティを、有効なSage 50 UK のユーザー資格情報に設定する必要があります。これらの値は、Sage 50 UK に ログインするために使用するものと同じです。

さらに、[接続]セクションのURL プロパティを、希望する会社データセットのアドレスに設定する必要がります。アドレスを取得するには、以下を行ってください:

  1. Sage 50 UK ソフトウェアを開きます。
  2. [Tools]->[Internet Options]をクリックします。
  3. [SData Settings]タブを選択します。
  4. [Sage 50 Accounts]の隣にある[Details]ボタンをクリックします。会社名のリストとそれに対応するデータセットのアドレスを含むウィンドウが表示されます。
  5. URL プロパティを希望する会社の隣にあるアドレスフィールドの値に設定します。

DSN を構成する際に、Max Rows プロパティを定めることも可能です。これによって返される行数が制限されるので、ビジュアライゼーション・レポートのデザイン時のパフォーマンスを向上させるのに役立ちます。

Data Connection Wizard で接続

以下のステップに従って、Excel のData Connection Wizard からDSN に接続します。

  1. [Data]タブで、[From Other Sources]->[From Data Connection Wizard]とクリックします。
  2. [Data Connection Wizard]で[ODBC DSN]オプションを選択します。
  3. リストから[ODBC DSN for Sage 50 UK]を選択します。
  4. 操作するテーブルを選択します。

    複数のテーブルをインポートする場合は、[Connect to a specific table]オプションの選択を解除します。データソースに接続したら、複数のテーブルを選択できます。[Finish]をクリックして[Data Connection Wizard]を閉じた後、[Select Table]ダイアログで[Enable selection of multiple tables]オプションを選択します。

  5. [Import Data]ダイアログで、データのインポート先を選択します。例えば、[Table]オプションと[Existing worksheet]オプションを選択します。次に、結果を出力するワークシートのセルをクリックします。
  6. [Insert]->[Power View]とクリックして新しいPower View レポートを作成します。

テーブルの作成

テーブルは、チャートやその他のデータの表現の開始点です。テーブルを作成するには、フィールドリストでカラムを選択します。テーブル名とカラム名をビューにドラッグアンドドロップすることも可能です。

データのビジュアライゼーションを作成

[Design]タブで、テーブルをチャートやその他のビジュアライゼーションに変更できます。