Tibco Spotfire から、ODBC 経由でSage 50 UK データに連携してビジュアライズ

詳細情報をご希望ですか?

無償トライアル:

ダウンロードへ

製品の詳細情報へ:

Sage UK ODBC Driver

Sage 50 UK ODBC ドライバーは、ODBC 接続をサポートする任意のアプリケーションからリアルタイムなSage 50 UK データに直接接続できるパワフルなツールです。標準のODBC ドライバーインタフェースを使用して、データベースのようにSage データにアクセスし、Sage の顧客、トランザクション、請求書、販売レシートなどの読み、書き、更新を実行できます。



ODBC 標準はユビキタスをサポートし、セルフサービスBI を簡単にします。ODBC Driver を使ってSage 50 UK をTIBCO Spotfire にローディングします。



この記事では、CData ODBC Driver for Sage 50 UK をTIBCO Spotfire で使う方法を説明します。データインポートウィザードを使ってのDSN(データソース名)に接続し、サンプルビジュアライゼーション上でビルドして簡単なダッシュボードを作成します。

  1. 接続プロパティの指定がまだの場合は、DSN (データソース名)で行います。Microsoft ODBC データソースアドミニストレーターを使ってODBC DSN を作成および設定できます。一般的な接続プロパティは以下のとおりです:

    • URL
    • User

    Microsoft ODBC データソースアドミニストレーターで必要なプロパティを設定する方法は、ヘルプドキュメントの「はじめに」をご参照ください。

    Note:Sage 50 UK 2012 以降のみサポートされています。

    「接続」セクションのUser およびPassword プロパティを、有効なSage 50 UK のユーザー資格情報に設定する必要があります。これらの値は、Sage 50 UK に ログインするために使用するものと同じです。

    さらに、「接続」セクションのURL プロパティを、希望する会社データセットのアドレスに設定する必要がります。アドレスを取得するには、以下を行ってください:

    1. Sage 50 UK ソフトウェアを開きます。
    2. 「Tools」->「Internet Options」をクリックします。
    3. 「SData Settings」タブを選択します。
    4. 「Sage 50 Accounts」の隣にある「Details」ボタンをクリックします。会社名のリストとそれに対応するデータセットのアドレスを含むウィンドウが表示されます。
    5. URL プロパティを希望する会社の隣にあるアドレスフィールドの値に設定します。

  2. [File]>[Add Data Tables]をクリックします。
  3. ライブデータを使いたい場合は、[Keep Data Table External]オプションをクリックします。このオプションは、データの変更をリアルタイムでダッシュボードに反映します。また、大量のデータを扱う場合に、ネットワークのロード回数を低減します。

    データをメモリにロードしてローカルで処理したい場合は、[Import Data Table]オプションをクリックします。このオプションは、オフラインでの使用、またはスローなネットワーク接続によりダッシュボードがインタラクティブでない場合に使用します。

  4. [Add]>[Database]をクリックします。
  5. [Data Source Type]メニューでODBC Provider を選択し[Configure]をクリックします。
  6. DSN を選択します。
  7. ダッシュボードに追加したいテーブルを選択します。この例ではTradingAccounts を使います。SQL クエリも指定できます。ドライバーは標準SQL シンタックスをサポートしています。
  8. テーブルを追加すると[Recommended Visualizations]ウィザードが表示されます。テーブルを選択すると、Spotfire はカラムのデータ型を使ってnumber、time、category カラムを検出します。この例ではNumbers セクションでFinanceBalance を、Categories セクションでName を使用しています。

[Recommended Visualizations]ウィザードでいくつかビジュアライズしたら、ダッシュボードにその他の修正を加えられます。例えば、ページにフィルタを適用することで、高確率なopportunities にズームインできます。フィルタを追加するには、[Filter]ボタンをクリックします。各クエリで利用可能なフィルタは、[Filters]ペインに表示されます。