Tableau Server へのSage 50 UK ダッシュボードの公開・パブリッシュ

詳細情報をご希望ですか?

無償トライアル:

ダウンロードへ

製品の詳細情報へ:

Sage UK ODBC Driver

Sage 50 UK ODBC ドライバーは、ODBC 接続をサポートする任意のアプリケーションからリアルタイムなSage 50 UK データに直接接続できるパワフルなツールです。標準のODBC ドライバーインタフェースを使用して、データベースのようにSage データにアクセスし、Sage の顧客、トランザクション、請求書、販売レシートなどの読み、書き、更新を実行できます。



CData ODBC driver for Sage 50 UK を使って、Tableau ダッシュボードにSage 50 UK をデータ連携。

エンタープライズBI にSage 50 UK 連携機能を追加しましょう。CData ODBC Driver for Sage 50 UK を使って、Tableau Server にSage 50 UK データをリアルタイム連携して、ダッシュボードを公開。企業の他のメンバーに連携レポート・ダッシュボードを共有しましょう。

この記事では、クライアントおよびサーバーでのでのDSN の設定、Sage 50 UK のデータソースのTableau Server へのパブリッシュ、ワークブック全体のTableau Server へのパブリッシュまでの手順を説明します。データソースをパブリッシュすると、Tableau Server で更新可能なワークブックを新しく作成することができるようになります。

※製品について詳しい情報をご希望の方は以下からお進みください。

Sage 50 UK にODBC DSNとして接続を確立

Tableau Desktop でワークブックやデータソースを作成して、Tableau Server にワークブックやデータソースをパブリッシュするには、デスクトップとサーバーのそれぞれのマシンでDSN 設定を行う必要があります。両方のマシンで厳密に同じ名前のDSN を作成して接続する必要があります。以下がSage 50 UK に接続するための情報です。Windows とLinux ODBC では設定に異なる点がありますので、ドキュメントを参照してください。

Note:Sage 50 UK 2012 以降のみサポートされています。

[接続]セクションのUser およびPassword プロパティを、有効なSage 50 UK のユーザー資格情報に設定する必要があります。これらの値は、Sage 50 UK に ログインするために使用するものと同じです。

さらに、[接続]セクションのURL プロパティを、希望する会社データセットのアドレスに設定する必要がります。アドレスを取得するには、以下を行ってください:

  1. Sage 50 UK ソフトウェアを開きます。
  2. [Tools]->[Internet Options]をクリックします。
  3. [SData Settings]タブを選択します。
  4. [Sage 50 Accounts]の隣にある[Details]ボタンをクリックします。会社名のリストとそれに対応するデータセットのアドレスを含むウィンドウが表示されます。
  5. URL プロパティを希望する会社の隣にあるアドレスフィールドの値に設定します。

DSN を設定する際には、Max Rows プロパティを設定することをお勧めします。これにより取得される行数が制限され、パフォーマンスを向上させます。

Windows

CData ODBC Driver for Sage 50 UK on Windows の場合は、DSN 設定はドライバーをインストールした後に行います。ドライバーをインストール語にDSN 設定画面が開きます。マイクロソフトのODBC データソースアドミニストレータから設定を行うことも可能です。

Linux

CData ODBC Driver for Sage 50 UK をLinux で利用する場合には、ドライバーのインストールでSystem DSN が事前定義されます。システムデータソースファイル(/etc/odbc.ini)を編集して、接続プロパティを入力することでDSN 設定を変更することができます。

/etc/odbc.ini

[CData Sage50UK Source] Driver = CData ODBC Driver for Sage 50 UK Description = My Description URL = http://your-server:5493/sdata/accounts50/GCRM/your-address User = Manager

コンフィグレーションファイルの詳細設定については、製品ヘルプを参照してください。

Sage 50 UK データソースをTableau に公開

Sage 50 UK への接続を確立したら、Tableau でSage 50 UK データソースをパブリッシュして、組織内のユーザーがSage 50 UK データに連携するワークブックを作成して利用できるようにします。

Tableau 上でSage 50 UK データソースを作成してパブリッシュする

  1. データソース画面で、その他のデータベース(ODBC) を選択します。システムDSN であるCData Sage50UK Sys を選択します。

    ドライバーのインストール時にシステムDSN とユーザーDSN を自動的に作成してくれます。Tableau Server では、システムDSN を使用します。

  2. [データベース]メニューでCData を選択します。
  3. [表]ボックスにテーブル名を入力、または[🔎]マーククリックして、テーブル一覧を表示させます。[新しいカスタムSQL]をクリックしてSQL クエリを入力することもできます。
  4. [データソース]ページで、テーブルをJOIN エリアにドラッグします。
  5. [サーバー]メニューで[ワークブックのパブリッシュ]-> (使用するデータソース)をクリックします。
  6. サーバーのURL を入力します。通常はTableau Server のuser name とpassword で認証します。次のような認証シナリオも可能です:
    • Tableau がKerberos を使用し、コンピューターに有効なActive Directory で接続している場合、Tableau がサーバーに接続します。
    • Tableau がSAML を使用する場合、外部プロバイダーのログインプロンプトが表示されます。
    • Tableau は、Active Directory の使用で設定されている場合、Windows username およびpassword を入力します。
  7. 次に、ダイアログにProject、Data Source や他のプロパティを入力します。スケジュール更新を設定する場合、Embedded Passsword を認証メニューで選択します。パブリッシュをクリックします。

これで、組織のユーザーがパブリッシュされたSage 50 UK データソースのワークブックを作成して共有することができるようになりました。

ワークブックのデータ更新(リフレッシュ)

クライアントマシンであるTableau Desktop とサーバーマシンであるTableau Server システムDSN を設定すると、接続しているSage 50 UK データソースをリフレッシュすることができます。Tableau Server のインターフェースで[データ]->[使用中のデータソース]->更新(Refresh)をクリックします。

Tableau Server でSage 50 UK データに連携する完成したワークブックをパブリッシュする

特定の完成したワークブックを組織内で共有する場合、Tableau Desktop でワークブックを作成し、直接Tableau Server にパブリッシュすることができます。

  1. 上記の1-5 の手順で、Sage 50 UK に接続し、データを取得します。
  2. [サーバー]-> [サインイン]をクリックして、サーバーの接続を設定します。通常はTableau Server のuser name とpassword で認証します。次のような認証シナリオも可能です:
    • Tableau がKerberos を使用し、コンピューターに有効なActive Directory で接続している場合、Tableau がサーバーに接続します。
    • Tableau がSAML を使用する場合、外部プロバイダーのログインプロンプトが表示されます。
    • Tableau は、Active Directory の使用で設定されている場合、Windows username およびpassword を入力します。
  3. 選択されたデータに対しビジュアライズするディメンションおよびメジャー選択し、チャートやブラフでビジュアライズを行います。
  4. ワークブックが完成したら、[サーバー]-> [ワークブックのパブリッシュ]でTableau Server ににパブリッシュします。
  5. 次に、ダイアログにProject、Data Source や他のプロパティを入力します。スケジュール更新を設定する場合、Embedded Passsword を認証メニューで選択します。パブリッシュをクリックします。

これで組織内のユーザーTableau Server のパブリッシュされたワークブックを参照することができるようになります。