今すぐお試しください!

製品の詳細CData ODBC Driver for Sage 50 UK を確認して、無償評価版をダウンロード:

今すぐダウンロード

Visio Shapes とSage 50 UK Data を連携

Visio master shapes での変更を自動的にSage 50 UK data に更新。

Automate the process of entering data into Visio diagrams and keeping your diagrams up to date with the CData ODBC Driver for Sage 50 UK. The driver surfaces Sage 50 UK data as an ODBC data source that can be accessed by applications with built-in ODBC support like Microsoft Office. This article shows how to create a simple diagram to start brainstorming about Visio projects linked to Sage 50 UK data.

Connect to Sage 50 UK as an ODBC Data Source

If you have not already, first specify connection properties in an ODBC DSN (data source name). This is the last step of the driver installation. You can use the Microsoft ODBC Data Source Administrator to create and configure ODBC DSNs.

Note: Only Sage 50 UK 2012 and above are supported.

The User and Password properties, under the Connection section, must be set to valid Sage 50 UK user credentials. These values will be the same used to log in to the Sage 50 UK software.

Additionally, the URL property, under the Connection section, will need to be set to the address of the company dataset desired. To obtain the address, do the following:

  1. If you have not already done so, open the Sage 50 UK software.
  2. Click Tools -> Internet Options.
  3. Select the SData Settings tab.
  4. Click the Details button next to Sage 50 Accounts. A window is displayed containing a list of company names along with the address to their corresponding datasets.
  5. Set the URL property to the value in the address field next to the company desired.

Connect Sage 50 UK Data to Diagrams

Follow the steps below to use the Data Selector Wizard to import data into your diagram.

  1. Open Visio and click File -> New. Open the Brainstorming template.
  2. On the Data tab, click Link Data to Shapes.
  3. Select the ODBC option and select ODBC DSN.
  4. Select the DSN for Sage 50 UK, select the table you want to import, and finish the wizard. This article uses TradingAccounts as an example.

Link Sage 50 UK Entities to Shapes

Follow the steps below to create a simple diagram that shows how to create shapes from your data, one of the ways to link Sage 50 UK entities to shapes:

  1. Click Brainstorming Shapes and drag a main topic onto the drawing page. Enter TradingAccounts as the text of the main topic.
  2. Click Topic.
  3. Select a row in the External Data window and drag it onto the drawing page.
  4. Right-click the Topic shape and click Data -> Edit Data Graphic.
  5. Click New Item.
  6. In the Data Field menu, select a column. In the Displayed As menu, select how to display them.
  7. Drag a few other Sage 50 UK entities onto the drawing page and add association lines back to the main topic, TradingAccounts. New topics have the same configuration: Numeric columns displayed in data bars stand out in contrast to other TradingAccounts entities.

You can refresh your diagram from the Data tab, synchronizing your shapes with the external Sage 50 UK data.

 
 
ダウンロード