Ready to get started?

Learn more about the CData ODBC Driver for SharePoint or download a free trial:

Download Now

Visio Shapes とSharePoint Data を連携

Visio master shapes での変更を自動的にSharePoint data に更新。

Automate the process of entering data into Visio diagrams and keeping your diagrams up to date with the CData ODBC Driver for SharePoint. The driver surfaces SharePoint data as an ODBC data source that can be accessed by applications with built-in ODBC support like Microsoft Office. This article shows how to create a simple diagram to start brainstorming about Visio projects linked to SharePoint data.

Connect to SharePoint as an ODBC Data Source

If you have not already, first specify connection properties in an ODBC DSN (data source name). This is the last step of the driver installation. You can use the Microsoft ODBC Data Source Administrator to create and configure ODBC DSNs.

Set the URL property to the base SharePoint site or to a sub-site. This allows you to query any lists and other SharePoint entities defined for the site or sub-site.

The User and Password properties, under the Authentication section, must be set to valid SharePoint user credentials when using SharePoint On-Premise.

If you are connecting to SharePoint Online, set the SharePointEdition to SHAREPOINTONLINE along with the User and Password connection string properties. For more details on connecting to SharePoint Online, see the "Getting Started" chapter of the help documentation

Connect SharePoint Data to Diagrams

Follow the steps below to use the Data Selector Wizard to import data into your diagram.

  1. Open Visio and click File -> New. Open the Brainstorming template.
  2. On the Data tab, click Link Data to Shapes.
  3. Select the ODBC option and select ODBC DSN.
  4. Select the DSN for SharePoint, select the table you want to import, and finish the wizard. This article uses MyCustomList as an example.

Link SharePoint Entities to Shapes

Follow the steps below to create a simple diagram that shows how to create shapes from your data, one of the ways to link SharePoint entities to shapes:

  1. Click Brainstorming Shapes and drag a main topic onto the drawing page. Enter MyCustomList as the text of the main topic.
  2. Click Topic.
  3. Select a row in the External Data window and drag it onto the drawing page.
  4. Right-click the Topic shape and click Data -> Edit Data Graphic.
  5. Click New Item.
  6. In the Data Field menu, select a column. In the Displayed As menu, select how to display them.
  7. Drag a few other SharePoint entities onto the drawing page and add association lines back to the main topic, MyCustomList. New topics have the same configuration: Numeric columns displayed in data bars stand out in contrast to other MyCustomList entities.

You can refresh your diagram from the Data tab, synchronizing your shapes with the external SharePoint data.

 
 
ダウンロード