Visio Shapes とShipStation Data を連携

詳細情報をご希望ですか?

無償トライアル:

ダウンロードへ

製品の詳細情報へ:

ShipStation ODBC Driver

ShipStation ODBC Driver を使って、ODBC 接続をサポートするあらゆるアプリケーション・ツールからShipStation にデータ連携。

ShipStation データにデータベースと同感覚でアクセスして、ShipStation データに使い慣れたODBC インターフェースで双方向連携。



Visio master shapes での変更を自動的にShipStation data に更新。

Automate the process of entering data into Visio diagrams and keeping your diagrams up to date with the CData ODBC Driver for ShipStation. The driver surfaces ShipStation data as an ODBC data source that can be accessed by applications with built-in ODBC support like Microsoft Office. This article shows how to create a simple diagram to start brainstorming about Visio projects linked to ShipStation data.

Connect to ShipStation as an ODBC Data Source

If you have not already, first specify connection properties in an ODBC DSN (data source name). This is the last step of the driver installation. You can use the Microsoft ODBC Data Source Administrator to create and configure ODBC DSNs.

Use the BASIC Authentication standard to connect.

  1. Login to your ShipStation account
  2. Click on the settings icon in the upper right corner. A column menu will show up on the left
  3. Click Account -> API Settings
  4. On the API Settings page, note the API Key and API Secret.

Authenticating to ShipStation

  • APIKey: Set this to the API key from the API settings page.
  • APISecret: Set this to the Secret key from the API settings page.

Connect ShipStation Data to Diagrams

Follow the steps below to use the Data Selector Wizard to import data into your diagram.

  1. Open Visio and click File -> New. Open the Brainstorming template.
  2. On the Data tab, click Link Data to Shapes.
  3. Select the ODBC option and select ODBC DSN.
  4. Select the DSN for ShipStation, select the table you want to import, and finish the wizard. This article uses Tags as an example.

Link ShipStation Entities to Shapes

Follow the steps below to create a simple diagram that shows how to create shapes from your data, one of the ways to link ShipStation entities to shapes:

  1. Click Brainstorming Shapes and drag a main topic onto the drawing page. Enter Tags as the text of the main topic.
  2. Click Topic.
  3. Select a row in the External Data window and drag it onto the drawing page.
  4. Right-click the Topic shape and click Data -> Edit Data Graphic.
  5. Click New Item.
  6. In the Data Field menu, select a column. In the Displayed As menu, select how to display them.
  7. Drag a few other ShipStation entities onto the drawing page and add association lines back to the main topic, Tags. New topics have the same configuration: Numeric columns displayed in data bars stand out in contrast to other Tags entities.

You can refresh your diagram from the Data tab, synchronizing your shapes with the external ShipStation data.