Visio Shapes とSQL Server Data を連携

詳細情報をご希望ですか?

無償トライアル:

ダウンロードへ

製品の詳細情報へ:

SQL Server ODBC Driver

ODBC 接続をサポートする任意のアプリケーションからMicrosoft SQL Server 互換データベースに接続します。

ODBC ドライバーを使用すると、カレントおよびレガシーバージョンのMS SQL との広範な互換性により、標準のJava Database 接続経由でSQL Server にダイレクトモードでアクセスできます。SSL、Kerberos、Integrated Security などを介したセキュアなSQL 接続および認証をサポートします。



Visio master shapes での変更を自動的にSQL Server data に更新。

Automate the process of entering data into Visio diagrams and keeping your diagrams up to date with the CData ODBC Driver for SQL Server. The driver surfaces SQL Server data as an ODBC data source that can be accessed by applications with built-in ODBC support like Microsoft Office. This article shows how to create a simple diagram to start brainstorming about Visio projects linked to SQL Server data.

Connect to SQL Server as an ODBC Data Source

If you have not already, first specify connection properties in an ODBC DSN (data source name). This is the last step of the driver installation. You can use the Microsoft ODBC Data Source Administrator to create and configure ODBC DSNs.

Microsoft SQL Server への接続

Microsoft SQL Server への接続には以下を入力します:

  • Server: SQL Server が稼働するサーバー名。
  • User: SQL Server に接続するユーザー名。
  • Password: 接続するユーザーのパスワード。
  • Database: SQL Server データベース名。

Azure SQL Server およびAzure Data Warehouse への接続

Azure SQL Server およびAzure Data Warehouse には以下の接続プロパティを入力して接続します:

  • Server: Azure 上のサーバー。Azure ポータルの「SQL databases」(もしくは「SQL data warehouses」)-> データベースを選択 -> 「Overview」-> 「Server name」で確認が可能です。
  • User: Azure に認証するユーザー名。
  • Password: 認証するユーザーのパスワード。
  • Database: Azure ポータルでSQL databases (or SQL warehouses) ページに表示されるデータベース名。

Connect SQL Server Data to Diagrams

Follow the steps below to use the Data Selector Wizard to import data into your diagram.

  1. Open Visio and click File -> New. Open the Brainstorming template.
  2. On the Data tab, click Link Data to Shapes.
  3. Select the ODBC option and select ODBC DSN.
  4. Select the DSN for SQL Server, select the table you want to import, and finish the wizard. This article uses Orders as an example.

Link SQL Server Entities to Shapes

Follow the steps below to create a simple diagram that shows how to create shapes from your data, one of the ways to link SQL Server entities to shapes:

  1. Click Brainstorming Shapes and drag a main topic onto the drawing page. Enter Orders as the text of the main topic.
  2. Click Topic.
  3. Select a row in the External Data window and drag it onto the drawing page.
  4. Right-click the Topic shape and click Data -> Edit Data Graphic.
  5. Click New Item.
  6. In the Data Field menu, select a column. In the Displayed As menu, select how to display them.
  7. Drag a few other SQL Server entities onto the drawing page and add association lines back to the main topic, Orders. New topics have the same configuration: Numeric columns displayed in data bars stand out in contrast to other Orders entities.

You can refresh your diagram from the Data tab, synchronizing your shapes with the external SQL Server data.