今すぐお試しください!

製品の詳細CData ODBC Driver for SQL Analysis Services を確認して、無償評価版をダウンロード:

今すぐダウンロード

Visio Shapes とSQL Analysis Services Data を連携

Visio master shapes での変更を自動的にSQL Analysis Services data に更新。

Automate the process of entering data into Visio diagrams and keeping your diagrams up to date with the CData ODBC Driver for SQL Analysis Services. The driver surfaces SQL Analysis Services data as an ODBC data source that can be accessed by applications with built-in ODBC support like Microsoft Office. This article shows how to create a simple diagram to start brainstorming about Visio projects linked to SQL Analysis Services data.

Connect to SQL Analysis Services as an ODBC Data Source

If you have not already, first specify connection properties in an ODBC DSN (data source name). This is the last step of the driver installation. You can use the Microsoft ODBC Data Source Administrator to create and configure ODBC DSNs.

接続するには、Url プロパティを有効なSQL Server Analysis Services エンドポイントに設定して認証を提供します。XMLA アクセスを使用して、HTTP 経由でホストされているSQL Server Analysis Services インスタンスに接続できます。 Microsoft ドキュメント configure HTTP access tを参照してSQL Server Analysis Services に接続してください。

SQL をSQL Server Analysis Services に実行するには、Analysis Services データの取得 を参照してください。接続ごとにメタデータを取得する代わりに、CacheLocation を設定できます。

  • HTTP 認証

    AuthScheme を"Basic" または"Digest" に設定してUser とPassword を設定します。CustomHeaders に他の認証値を指定します。

  • Windows (NTLM)

    Windows のUser とPassword を設定して、AuthScheme をNTLM に設定します。

  • Kerberos およびKerberos Delegation

    Kerberos を認証するには、AuthScheme をNEGOTIATE に設定します。Kerberos 委任を使うには、AuthScheme をKERBEROSDELEGATION に設定します。必要があれば、User、Password およびKerberosSPN を設定します。デフォルトでは、本製品 は指定されたUrl でSPN と通信しようと試みます。

  • SSL/TLS:

    デフォルトでは、本製品 はサーバーの証明書をシステムの信頼できる証明書ストアと照合してSSL/TLS のネゴシエーションを試みます。別の証明書を指定するには、利用可能なフォーマットについてSSLServerCert プロパティを参照してください。

You can then access any cube as a relational table: When you connect the data provider retrieves SSAS metadata and dynamically updates the table schemas. Instead of retrieving metadata every connection, you can set the CacheLocation property to automatically cache to a simple file-based store.

See the Getting Started section of the CData documentation, under Retrieving Analysis Services Data, to execute SQL-92 queries to the cubes.

Connect SQL Analysis Services Data to Diagrams

Follow the steps below to use the Data Selector Wizard to import data into your diagram.

  1. Open Visio and click File -> New. Open the Brainstorming template.
  2. On the Data tab, click Link Data to Shapes.
  3. Select the ODBC option and select ODBC DSN.
  4. Select the DSN for SQL Analysis Services, select the table you want to import, and finish the wizard. This article uses Adventure_Works as an example.

Link SQL Analysis Services Entities to Shapes

Follow the steps below to create a simple diagram that shows how to create shapes from your data, one of the ways to link SQL Analysis Services entities to shapes:

  1. Click Brainstorming Shapes and drag a main topic onto the drawing page. Enter Adventure_Works as the text of the main topic.
  2. Click Topic.
  3. Select a row in the External Data window and drag it onto the drawing page.
  4. Right-click the Topic shape and click Data -> Edit Data Graphic.
  5. Click New Item.
  6. In the Data Field menu, select a column. In the Displayed As menu, select how to display them.
  7. Drag a few other SQL Analysis Services entities onto the drawing page and add association lines back to the main topic, Adventure_Works. New topics have the same configuration: Numeric columns displayed in data bars stand out in contrast to other Adventure_Works entities.

You can refresh your diagram from the Data tab, synchronizing your shapes with the external SQL Analysis Services data.

 
 
ダウンロード