Tibco Spotfire から、ODBC 経由でSugar CRM データに連携してビジュアライズ

詳細情報をご希望ですか?

無償トライアル:

ダウンロードへ

製品の詳細情報へ:

Sugar ODBC Driver

SugarCRM ODBC ドライバーは、ODBC 接続をサポートする任意のアプリケーションからリアルタイムなSugarCRM アカウントデータに直接接続できるパワフルなツールです。標準のODBC ドライバーインタフェースを使用して、データベースのようにCRM データにアクセスし、潜在顧客、連絡先、営業案件、アカウントなどの読み、書き、更新を実行できます。



ODBC 標準はユビキタスをサポートし、セルフサービスBI を簡単にします。ODBC Driver を使ってSugar CRM をTIBCO Spotfire にローディングします。



この記事では、CData ODBC Driver for Sugar CRM をTIBCO Spotfire で使う方法を説明します。データインポートウィザードを使ってのDSN(データソース名)に接続し、サンプルビジュアライゼーション上でビルドして簡単なダッシュボードを作成します。

  1. 接続プロパティの指定がまだの場合は、DSN (データソース名)で行います。Microsoft ODBC データソースアドミニストレーターを使ってODBC DSN を作成および設定できます。一般的な接続プロパティは以下のとおりです:

    • User
    • Password
    • URL
    • CacheMetadata

    Microsoft ODBC データソースアドミニストレーターで必要なプロパティを設定する方法は、ヘルプドキュメントの「はじめに」をご参照ください。

    本製品をSugarCRM に認証するには、以下を有効なSugarCRM ユーザー資格情報に設定する必要があります。User:SugarCRM アカウントのユーザー。Password:SugarCRM アカウントのパスワード。

    OAuth consumer key とconsumer secret は、Admin -> OAuth Keys で生成することができます。OAuthClientId にOAuth consumer key を、OAuthClientSecret にconsumer secret を設定します。

    さらに、SugarCRM への接続を確立するには以下を指定します。URL:'http://{sugar crm instance}.com' の形式で、SugarCRM アカウントに紐付いているURL に設定。Platform:認証中にログインの競合が発生した場合は、SugarCRM UI で作成したプラットフォームのいずれかに設定。

    SugarCRM メタデータの取得は高負荷になる可能性があることに注意してください。メタデータのキャッシュ で説明しているように、メタデータをローカルに格納することをお勧めします。

  2. [File]>[Add Data Tables]をクリックします。
  3. ライブデータを使いたい場合は、[Keep Data Table External]オプションをクリックします。このオプションは、データの変更をリアルタイムでダッシュボードに反映します。また、大量のデータを扱う場合に、ネットワークのロード回数を低減します。

    データをメモリにロードしてローカルで処理したい場合は、[Import Data Table]オプションをクリックします。このオプションは、オフラインでの使用、またはスローなネットワーク接続によりダッシュボードがインタラクティブでない場合に使用します。

  4. [Add]>[Database]をクリックします。
  5. [Data Source Type]メニューでODBC Provider を選択し[Configure]をクリックします。
  6. DSN を選択します。
  7. ダッシュボードに追加したいテーブルを選択します。この例ではAccounts を使います。SQL クエリも指定できます。ドライバーは標準SQL シンタックスをサポートしています。
  8. テーブルを追加すると[Recommended Visualizations]ウィザードが表示されます。テーブルを選択すると、Spotfire はカラムのデータ型を使ってnumber、time、category カラムを検出します。この例ではNumbers セクションでAnnualRevenue を、Categories セクションでName を使用しています。

[Recommended Visualizations]ウィザードでいくつかビジュアライズしたら、ダッシュボードにその他の修正を加えられます。例えば、ページにフィルタを適用することで、高確率なopportunities にズームインできます。フィルタを追加するには、[Filter]ボタンをクリックします。各クエリで利用可能なフィルタは、[Filters]ペインに表示されます。