Visio Shapes とSugar CRM Data を連携

詳細情報をご希望ですか?

無償トライアル:

ダウンロードへ

製品の詳細情報へ:

Sugar ODBC Driver

SugarCRM ODBC ドライバーは、ODBC 接続をサポートする任意のアプリケーションからリアルタイムなSugarCRM アカウントデータに直接接続できるパワフルなツールです。標準のODBC ドライバーインタフェースを使用して、データベースのようにCRM データにアクセスし、潜在顧客、連絡先、営業案件、アカウントなどの読み、書き、更新を実行できます。



Visio master shapes での変更を自動的にSugar CRM data に更新。

Automate the process of entering data into Visio diagrams and keeping your diagrams up to date with the CData ODBC Driver for Sugar CRM. The driver surfaces Sugar CRM data as an ODBC data source that can be accessed by applications with built-in ODBC support like Microsoft Office. This article shows how to create a simple diagram to start brainstorming about Visio projects linked to Sugar CRM data.

Connect to Sugar CRM as an ODBC Data Source

If you have not already, first specify connection properties in an ODBC DSN (data source name). This is the last step of the driver installation. You can use the Microsoft ODBC Data Source Administrator to create and configure ODBC DSNs.

本製品をSugarCRM に認証するには、以下を有効なSugarCRM ユーザー資格情報に設定する必要があります。User:SugarCRM アカウントのユーザー。Password:SugarCRM アカウントのパスワード。

OAuth consumer key とconsumer secret は、Admin -> OAuth Keys で生成することができます。OAuthClientId にOAuth consumer key を、OAuthClientSecret にconsumer secret を設定します。

さらに、SugarCRM への接続を確立するには以下を指定します。URL:'http://{sugar crm instance}.com' の形式で、SugarCRM アカウントに紐付いているURL に設定。Platform:認証中にログインの競合が発生した場合は、SugarCRM UI で作成したプラットフォームのいずれかに設定。

SugarCRM メタデータの取得は高負荷になる可能性があることに注意してください。メタデータのキャッシュ で説明しているように、メタデータをローカルに格納することをお勧めします。

Connect Sugar CRM Data to Diagrams

Follow the steps below to use the Data Selector Wizard to import data into your diagram.

  1. Open Visio and click File -> New. Open the Brainstorming template.
  2. On the Data tab, click Link Data to Shapes.
  3. Select the ODBC option and select ODBC DSN.
  4. Select the DSN for Sugar CRM, select the table you want to import, and finish the wizard. This article uses Accounts as an example.

Link Sugar CRM Entities to Shapes

Follow the steps below to create a simple diagram that shows how to create shapes from your data, one of the ways to link Sugar CRM entities to shapes:

  1. Click Brainstorming Shapes and drag a main topic onto the drawing page. Enter Accounts as the text of the main topic.
  2. Click Topic.
  3. Select a row in the External Data window and drag it onto the drawing page.
  4. Right-click the Topic shape and click Data -> Edit Data Graphic.
  5. Click New Item.
  6. In the Data Field menu, select a column. In the Displayed As menu, select how to display them.
  7. Drag a few other Sugar CRM entities onto the drawing page and add association lines back to the main topic, Accounts. New topics have the same configuration: Numeric columns displayed in data bars stand out in contrast to other Accounts entities.

You can refresh your diagram from the Data tab, synchronizing your shapes with the external Sugar CRM data.