Visio Shapes とTrello Data を連携

詳細情報をご希望ですか?

無償トライアル:

ダウンロードへ

製品の詳細情報へ:

Trello ODBC Driver

Trello ODBC Driver を使って、ODBC 接続をサポートするあらゆるアプリケーション・ツールからTrello データに連携。

Trello にデータベースのようにアクセス - Trello のLists、Cards、Boards にODBC インターフェースで接続。



Visio master shapes での変更を自動的にTrello data に更新。

Automate the process of entering data into Visio diagrams and keeping your diagrams up to date with the CData ODBC Driver for Trello. The driver surfaces Trello data as an ODBC data source that can be accessed by applications with built-in ODBC support like Microsoft Office. This article shows how to create a simple diagram to start brainstorming about Visio projects linked to Trello data.

Connect to Trello as an ODBC Data Source

If you have not already, first specify connection properties in an ODBC DSN (data source name). This is the last step of the driver installation. You can use the Microsoft ODBC Data Source Administrator to create and configure ODBC DSNs.

Trello は、トークンベース認証を使用して、サードパーティアプリケーションにAPI へのアクセスを許可します。ユーザーがアプリケーションにデータへのアクセスを許可すると、アプリケーションにはTrello のAPI へのリクエストに使用できるトークンが付与されます。 Trello のAPI には2通りの方法でアクセスできます。1つ目はTrello 独自の認可ルートで、2つ目はOAuth1.0 を使用する方法です。

  • 認可ルート: 登録の時点で、Trello はAPI キーとトークンをアカウントに割り当てます。認可ルート経由で接続する方法については、ヘルプドキュメントの「認可ルートの使用」を参照してください。
  • OAuth ルート: 認可の使用と同様に、OAuth は、アカウントの作成時にApplication Id とSecret を作成します。接続方法については、ヘルプドキュメントの「OAuth 認証の使用」を参照してください。

Connect Trello Data to Diagrams

Follow the steps below to use the Data Selector Wizard to import data into your diagram.

  1. Open Visio and click File -> New. Open the Brainstorming template.
  2. On the Data tab, click Link Data to Shapes.
  3. Select the ODBC option and select ODBC DSN.
  4. Select the DSN for Trello, select the table you want to import, and finish the wizard. This article uses Boards as an example.

Link Trello Entities to Shapes

Follow the steps below to create a simple diagram that shows how to create shapes from your data, one of the ways to link Trello entities to shapes:

  1. Click Brainstorming Shapes and drag a main topic onto the drawing page. Enter Boards as the text of the main topic.
  2. Click Topic.
  3. Select a row in the External Data window and drag it onto the drawing page.
  4. Right-click the Topic shape and click Data -> Edit Data Graphic.
  5. Click New Item.
  6. In the Data Field menu, select a column. In the Displayed As menu, select how to display them.
  7. Drag a few other Trello entities onto the drawing page and add association lines back to the main topic, Boards. New topics have the same configuration: Numeric columns displayed in data bars stand out in contrast to other Boards entities.

You can refresh your diagram from the Data tab, synchronizing your shapes with the external Trello data.