Visio Shapes とX-Cart Data を連携

詳細情報をご希望ですか?

無償トライアル:

ダウンロードへ

製品の詳細情報へ:

X-Cart ODBC Driver



Visio master shapes での変更を自動的にX-Cart data に更新。

Automate the process of entering data into Visio diagrams and keeping your diagrams up to date with the CData ODBC Driver for X-Cart. The driver surfaces X-Cart data as an ODBC data source that can be accessed by applications with built-in ODBC support like Microsoft Office. This article shows how to create a simple diagram to start brainstorming about Visio projects linked to X-Cart data.

Connect to X-Cart as an ODBC Data Source

If you have not already, first specify connection properties in an ODBC DSN (data source name). This is the last step of the driver installation. You can use the Microsoft ODBC Data Source Administrator to create and configure ODBC DSNs.

An API Key must be created for your XCart Installation. In order to obtain the API Key, you need to install and configure the REST API Module for your X-Cart installation.

  • Login to your X-Cart Installation. Click on My addons on the bottom of the left side-bar navigation panel.
  • Search for REST API Module. Install the Module.
  • After the module has been installed, you need to set it up.
    • Go to the Settings section for the REST API Module.
    • On the settings page specify the API Key (only read)
  • Set the ApiKey and Url to the connection property to connect to data.

Connect X-Cart Data to Diagrams

Follow the steps below to use the Data Selector Wizard to import data into your diagram.

  1. Open Visio and click File -> New. Open the Brainstorming template.
  2. On the Data tab, click Link Data to Shapes.
  3. Select the ODBC option and select ODBC DSN.
  4. Select the DSN for X-Cart, select the table you want to import, and finish the wizard. This article uses PROFILES as an example.

Link X-Cart Entities to Shapes

Follow the steps below to create a simple diagram that shows how to create shapes from your data, one of the ways to link X-Cart entities to shapes:

  1. Click Brainstorming Shapes and drag a main topic onto the drawing page. Enter PROFILES as the text of the main topic.
  2. Click Topic.
  3. Select a row in the External Data window and drag it onto the drawing page.
  4. Right-click the Topic shape and click Data -> Edit Data Graphic.
  5. Click New Item.
  6. In the Data Field menu, select a column. In the Displayed As menu, select how to display them.
  7. Drag a few other X-Cart entities onto the drawing page and add association lines back to the main topic, PROFILES. New topics have the same configuration: Numeric columns displayed in data bars stand out in contrast to other PROFILES entities.

You can refresh your diagram from the Data tab, synchronizing your shapes with the external X-Cart data.