Ready to get started?

Learn more about the CData ODBC Driver for AvaTax or download a free trial:

Download Now

Link Visio Shapes to AvaTax Data

Automatically update AvaTax data with the changes you make to Visio master shapes.

Automate the process of entering data into Visio diagrams and keeping your diagrams up to date with the CData ODBC Driver for AvaTax. The driver surfaces AvaTax data as an ODBC data source that can be accessed by applications with built-in ODBC support like Microsoft Office. This article shows how to create a simple diagram to start brainstorming about Visio projects linked to AvaTax data.

Connect to AvaTax as an ODBC Data Source

If you have not already, first specify connection properties in an ODBC DSN (data source name). This is the last step of the driver installation. You can use the Microsoft ODBC Data Source Administrator to create and configure ODBC DSNs.

The primary method for performing basic authentication is to provide your login credentials, as follows:

  • User: Set this to your username.
  • Password: Set this to your password.

Optionally, if you are making use of a sandbox environment, set the following:

  • UseSandbox: Set this to true if you are authenticating with a sandbox account.

Authenticating Using Account Number and License Key

Alternatively, you can authenticate using your account number and license key. Connect to data using the following:

  • AccountId: Set this to your Account Id. The Account Id is listed in the upper right hand corner of the admin console.
  • LicenseKey: Set this to your Avalara Avatax license key. You can generate a license key by logging into Avalara Avatax as an account adminstrator and navigating to Settings -> Reset License Key.

Connect AvaTax Data to Diagrams

Follow the steps below to use the Data Selector Wizard to import data into your diagram.

  1. Open Visio and click File -> New. Open the Brainstorming template.
  2. On the Data tab, click Link Data to Shapes.
  3. Select the ODBC option and select ODBC DSN.
  4. Select the DSN for AvaTax, select the table you want to import, and finish the wizard. This article uses Transactions as an example.

Link AvaTax Entities to Shapes

Follow the steps below to create a simple diagram that shows how to create shapes from your data, one of the ways to link AvaTax entities to shapes:

  1. Click Brainstorming Shapes and drag a main topic onto the drawing page. Enter Transactions as the text of the main topic.
  2. Click Topic.
  3. Select a row in the External Data window and drag it onto the drawing page.
  4. Right-click the Topic shape and click Data -> Edit Data Graphic.
  5. Click New Item.
  6. In the Data Field menu, select a column. In the Displayed As menu, select how to display them.
  7. Drag a few other AvaTax entities onto the drawing page and add association lines back to the main topic, Transactions. New topics have the same configuration: Numeric columns displayed in data bars stand out in contrast to other Transactions entities.

You can refresh your diagram from the Data tab, synchronizing your shapes with the external AvaTax data.