Link Visio Shapes to Azure Synapse Data

Ready to get started?

Download for a free trial:

Download Now

Learn more:

Azure Synapse ODBC Driver

The Azure Synapse ODBC Driver is a powerful tool that allows you to connect with live data from Azure Synapse, directly from any applications that support ODBC connectivity.

Access Azure Synapse data like you would a database - read, write, and update Azure Synapse. through a standard ODBC Driver interface.



Automatically update Azure Synapse data with the changes you make to Visio master shapes.

Automate the process of entering data into Visio diagrams and keeping your diagrams up to date with the CData ODBC Driver for Azure Synapse. The driver surfaces Azure Synapse data as an ODBC data source that can be accessed by applications with built-in ODBC support like Microsoft Office. This article shows how to create a simple diagram to start brainstorming about Visio projects linked to Azure Synapse data.

Connect to Azure Synapse as an ODBC Data Source

If you have not already, first specify connection properties in an ODBC DSN (data source name). This is the last step of the driver installation. You can use the Microsoft ODBC Data Source Administrator to create and configure ODBC DSNs.

Connecting to Azure Synapse

In addition to providing authentication (see below), set the following properties to connect to a Azure Synapse database:

  • Server: The server running Azure. You can find this by logging into the Azure portal and navigating to Azure Synapse Analytics -> Select your database -> Overview -> Server name.
  • Database: The name of the database, as seen in the Azure portal on the Azure Synapse Analytics page.

Authenticating to Azure Synapse

Connect to Azure Synapse using the following properties:

  • User: The username provided for authentication with Azure.
  • Password: The password associated with the authenticating user.

Connect Azure Synapse Data to Diagrams

Follow the steps below to use the Data Selector Wizard to import data into your diagram.

  1. Open Visio and click File -> New. Open the Brainstorming template.
  2. On the Data tab, click Link Data to Shapes.
  3. Select the ODBC option and select ODBC DSN.
  4. Select the DSN for Azure Synapse, select the table you want to import, and finish the wizard. This article uses Products as an example.

Link Azure Synapse Entities to Shapes

Follow the steps below to create a simple diagram that shows how to create shapes from your data, one of the ways to link Azure Synapse entities to shapes:

  1. Click Brainstorming Shapes and drag a main topic onto the drawing page. Enter Products as the text of the main topic.
  2. Click Topic.
  3. Select a row in the External Data window and drag it onto the drawing page.
  4. Right-click the Topic shape and click Data -> Edit Data Graphic.
  5. Click New Item.
  6. In the Data Field menu, select a column. In the Displayed As menu, select how to display them.
  7. Drag a few other Azure Synapse entities onto the drawing page and add association lines back to the main topic, Products. New topics have the same configuration: Numeric columns displayed in data bars stand out in contrast to other Products entities.

You can refresh your diagram from the Data tab, synchronizing your shapes with the external Azure Synapse data.