Ready to get started?

Learn more about the CData ODBC Driver for eBay or download a free trial:

Download Now

Import and Visualize eBay Data in Power View

Create data visualizations based on eBay data in Excel.

You can use the built-in ODBC support in Excel to rapidly create Power View reports featuring eBay data. This article shows how to use the Data Connection Wizard, accessible from the Data ribbon, to import eBay data into a Power View report.

Connect to eBay as an ODBC Data Source

If you have not already, first specify connection properties in an ODBC DSN (data source name). This is the last step of the driver installation. You can use the Microsoft ODBC Data Source Administrator to create and configure ODBC DSNs.

If you will be accessing your own account, you can generate an OAuthAccessToken from your developer account dashboard. You can also allow other users to securely access their own accounts.

Both of these methods require you to create an application key set to obtain values for the following connection properties: AppId, CertId, DevId, and SiteId.

The user consent flow additionally requires the RuName and CallbackURL.

See the "Getting Started" chapter in the help documentation for a guide to using OAuth.

When you configure the DSN, you may also want to set the Max Rows connection property. This will limit the number of rows returned, which is especially helpful for improving performance when designing reports and visualizations.

Connect with the Data Connection Wizard

Follow the steps below to connect to the DSN from the Data Connection Wizard in Excel.

  1. On the Data tab, click From Other Sources -> From Data Connection Wizard.
  2. In the Data Connection Wizard, select the ODBC DSN option.
  3. Select the ODBC DSN for eBay from the list.
  4. Select the tables you want to work with.

    If you want to import multiple tables, deselect the "Connect to a specific table" option. After you connect to the data source, you can select multiple tables: After you click Finish to close the Data Connection Wizard, select the "Enable selection of multiple tables" option in the Select Table dialog.

  5. In the Import Data dialog, select the destination for your data. For example, select the Table option and the Existing worksheet option. Then click the cell in your worksheet where results should be output.
  6. Click Insert -> Power View to create a new Power View report.

Create a Table

Tables are the starting point for charts and other representations of your data. To create a table, select a column in the field list. You can also drag and drop table names and column names onto the view.

Create Data Visualizations

On the Design tab, you can change tables into charts and other visualizations.