Ready to get started?

Learn more about the CData ODBC Driver for FTP or download a free trial:

Download Now

Link Visio Shapes to FTP Data

Automatically update FTP data with the changes you make to Visio master shapes.

Automate the process of entering data into Visio diagrams and keeping your diagrams up to date with the CData ODBC Driver for FTP. The driver surfaces FTP data as an ODBC data source that can be accessed by applications with built-in ODBC support like Microsoft Office. This article shows how to create a simple diagram to start brainstorming about Visio projects linked to FTP data.

Connect to FTP as an ODBC Data Source

If you have not already, first specify connection properties in an ODBC DSN (data source name). This is the last step of the driver installation. You can use the Microsoft ODBC Data Source Administrator to create and configure ODBC DSNs.

To connect to FTP or SFTP servers, specify at least RemoteHost and FileProtocol. Specify the port with RemotePort.

Set User and Password to perform Basic authentication. Set SSHAuthMode to use SSH authentication. See the Getting Started section of the data provider help documentation for more information on authenticating via SSH.

Set SSLMode and SSLServerCert to secure connections with SSL.

The data provider lists the tables based on the available folders in your FTP server. Set the following connection properties to control the relational view of the file system:

  • RemotePath: Set this to the current working directory.
  • TableDepth: Set this to control the depth of folders to list as views.
  • FileRetrievalDepth: Set this to retrieve and list files recursively from the root table.

Stored Procedures are available to download files, upload files, and send protocol commands. See the Data Model chapter of the FTP data provider documentation for more information.

Connect FTP Data to Diagrams

Follow the steps below to use the Data Selector Wizard to import data into your diagram.

  1. Open Visio and click File -> New. Open the Brainstorming template.
  2. On the Data tab, click Link Data to Shapes.
  3. Select the ODBC option and select ODBC DSN.
  4. Select the DSN for FTP, select the table you want to import, and finish the wizard. This article uses MyDirectory as an example.

Link FTP Entities to Shapes

Follow the steps below to create a simple diagram that shows how to create shapes from your data, one of the ways to link FTP entities to shapes:

  1. Click Brainstorming Shapes and drag a main topic onto the drawing page. Enter MyDirectory as the text of the main topic.
  2. Click Topic.
  3. Select a row in the External Data window and drag it onto the drawing page.
  4. Right-click the Topic shape and click Data -> Edit Data Graphic.
  5. Click New Item.
  6. In the Data Field menu, select a column. In the Displayed As menu, select how to display them.
  7. Drag a few other FTP entities onto the drawing page and add association lines back to the main topic, MyDirectory. New topics have the same configuration: Numeric columns displayed in data bars stand out in contrast to other MyDirectory entities.

You can refresh your diagram from the Data tab, synchronizing your shapes with the external FTP data.